Problem getting CHDK installed...

  • 8 Replies
  • 1325 Views
Problem getting CHDK installed...
« on: 18 / June / 2012, 22:15:56 »
Advertisements
I have an Ixus 310HS (firmware version 101a); I have DISKBOOT.BIN and PS.F12 on the SD card. I followed the instructions (on the ‘Prepare your SD card’ page, http://chdk.wikia.com/wiki/Bootable_SD_card), see below, but step 6 didn’t start CHDK. What am I doing wrong?

UPDATE: tried again and got CHDK working but only if the card is in the unlocked position... When locked I can't access CHDK.

UPDATE 2: OK, I got to the end of the process, but this sentence needs to specify the method for turning the camera back on:
"Now each time that you turn your camera on, the CHDK logo should briefly display automatically, indicating that CHDK has successfully loaded". Given that the most recent instruction re turning the camera on was to use the Play button, the newbie now doesn't know whether that instruction still applies, or whether after completing this process that the On/Off button is used...

Geoff
« Last Edit: 18 / June / 2012, 23:06:16 by geoff1859 »

Re: Problem getting CHDK installed...
« Reply #1 on: 18 / June / 2012, 22:59:52 »
but step 6 didn’t start CHDK. What am I doing wrong?
As the author of that page,  I'm humbled to realize how many different "step 6"'s are on there. Sorry.  Which one are you stuck at ?

UPDATE: tried again and got CHDK working but only if the card is in the unlocked position... When locked I can't access CHDK.
CHDK has two loading mechanisms -  the "Firmware update" method and the "SD Card Locked" method.  Both methods are valid but require different setup for the SD card.

If you can't get access when you have "locked" the SD card then you have not formatted it to be bootable.

« Last Edit: 18 / June / 2012, 23:06:27 by waterwingz »
Ported : A1200  SD940  G10  Powershot N  G16*

Re: Problem getting CHDK installed...
« Reply #2 on: 18 / June / 2012, 23:08:21 »
Thanks waterwingz. I think that I've now worked it out. Now to work out how to get motion detection working...

Geoff

Re: Problem getting CHDK installed...
« Reply #3 on: 18 / June / 2012, 23:10:22 »
Thanks waterwingz. I think that I've now worked it out. Now to work out how to get motion detection working...
Good !

As a feedback mechanism for improvements,  was there anything in particular that got you hung up?
 
We can talk about MD later .....
Ported : A1200  SD940  G10  Powershot N  G16*


Re: Problem getting CHDK installed...
« Reply #4 on: 18 / June / 2012, 23:19:53 »
Waterwingz, I found that there was too much information in too many places, resulting in never being sure whether I was on the right track. And I'm still not sure. I suspect that I've done something wrong because even though I've gone through what seems to be the entire process, when I turn the camera on (either via On/Off or Play), I get the black screen with 'No image' in the center, CHDK in upper left, and MENU lower right. Is that what I should see? I expected the lens to open and the CHDK text to be superimposed.

Thanks for your interest in feedback. (Speaking of which... the defaced letters that have to be identified before I can post are often quite unreadable even for a human...)
 
Geoff

Re: Problem getting CHDK installed...
« Reply #5 on: 18 / June / 2012, 23:41:11 »
Waterwingz, I found that there was too much information in too many places, resulting in never being sure whether I was on the right track.
That's why we did the Bootable_SD_card[Bootable SD Card page

Quote
And I'm still not sure. I suspect that I've done something wrong because even though I've gone through what seems to be the entire process, when I turn the camera on (either via On/Off or Play), I get the black screen with 'No image' in the center
Normal if there are no jpg pictures on your SD card .. the Canon firmware generates that message - not CHDK
Quote
CHDK in upper left
hmm ... not sure I've ever seen that ..

Quote
,and MENU lower right.
ditto my comment above

Quote
Is that what I should see? I expected the lens to open and the CHDK text to be superimposed.
The lens will only open when you start the camera by holding down the On/Off button for 2 seconds.  Otherwise the caerma starts in playback mode.

Quote
Thanks for your interest in feedback. (Speaking of which... the defaced letters that have to be identified before I can post are often quite unreadable even for a human...)
 
Still trying to find out why people complain about seeing that.  Are you are a registered user and logged in?  It is my understanding that it should not occur.
« Last Edit: 18 / June / 2012, 23:44:24 by waterwingz »
Ported : A1200  SD940  G10  Powershot N  G16*

Re: Problem getting CHDK installed...
« Reply #6 on: 19 / June / 2012, 00:02:23 »
Waterwingz, thanks for your responses.

I think that many of us try to achieve the desired result with minimal reading of instructions. I'll now spend some time doing some reading, and get back to you if I need some help with MD.

(And yes, deciphering the letters isn't an every time thing. Sorry, a trivial point really.)

Geoff

Re: Problem getting CHDK installed...
« Reply #7 on: 19 / June / 2012, 00:22:03 »
I think that many of us try to achieve the desired result with minimal reading of instructions. I'll now spend some time doing some reading, and get back to you if I need some help with MD.
One of my other "rewrite" attempts : Motion Detection.  Its a wiki - feel free to correct any mistakes or omissions.
Ported : A1200  SD940  G10  Powershot N  G16*


Re: Problem getting CHDK installed...
« Reply #8 on: 19 / June / 2012, 00:53:12 »
Quote
CHDK in upper left
hmm ... not sure I've ever seen that ..

Quote
,and MENU lower right.
ditto my comment above

On touch-screen cameras these are on-screen buttons for CHDK functions. I don't know how do they work because I do not own such camera, but as far as I remember I have seen some screenshots.
if (2*b || !2*b) {
    cout<<question
}

Compile error: poor Yorick

 

Related Topics