CHDK on an EOS 350D, Cardtricks from Wine on Ubuntu machine ... problems! - General Discussion and Assistance - CHDK Forum  

CHDK on an EOS 350D, Cardtricks from Wine on Ubuntu machine ... problems!

  • 2 Replies
Has anyone succeeded in putting CHDK onto an EOS 350D from a Linux machine?

I have tried, and failed. Here are some of the things I've done so far:

a) I follow the instructions on and am following the 7 steps listed there. I get as far as the end of point 3 i.e. the card has had scanled.fir put onto it, it has been in the camera, the firmware upgrade ran, the blue light came on, I waited 30 seconds after it stopped blinking, I turned off the camera, took out the battery, slipped the battery back in and left the camera off.

So now I am at step 4 - since I am on a Ubuntu machine I try to run cardtricks from Wine. I do get the cardtricks menu
up and as I insert the CF card into the reader the software blinks once and then I can click on the card icon and get a menu from which I choose the CF card. Cardtricks then refreshes and indicates that the card has NTFS on it.

As step 4 says I must format the card I click on the "format as FAT" button and I get the warning that all data will be destroyed, I click OK, then I get the write protect tab warning ... um ... step 5 says not to worry ... ok ... but what shall I do? Shall I press the OK button? If I do nothing else happens. So, no changes are made to the card.

I then start up gparted to see the card and it is formatted as one big block of almost 1 Gbyte and is bootable. But gparted says it is FAT16.

That card was last formatted in the camera.

Now, as there are many more mysteries here I will start somewhere near the start:

Q: can anyone say why cardtricks under wine does not format the card? Is it bad that cardtricks sees NTFS and not FAT16 on the card?

Sorry for the length of this!

Camera: EOS 350D, Firmware 1.0.3
1 GB CF II card - no write protect tab.
PC with Ubuntu 9.10
Wine 1.0.1 is installed
Catrdicks seems to be 1.44, i.e. I have "Cardtricks 144.exe"
card reader is from Trust


Offline whim

  • ******
  • 2046
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
This thread might help:,4214.0.html

Just use your camera to format the card, then check here,4214.msg44249.html#msg44249 how to  make it bootable

« Last Edit: 28 / March / 2010, 09:05:22 by whim »

Sorry for unearthing this old post ... but I imagine it could help someone:

This is how I did to get the CHDK working with Ubuntu soft.
None of the tools (CardTricks 143, ~144, ~145, EOSCard, licks, etc.) worked for me.

-> Format CF in camera ...
Put CF in Card Reader, open GParted
Unmount CF from within GParted
Change Card Label from EOS_DIGITAL to EOS_DEVELOP & apply change.

Open console, dump first 512 bytes of 1st CF partition to file:
Code: [Select]
~$ sudo dd if=/dev/sdb1 of=mbr.bin bs=512 count=1
~$ sudo chown user:user mbr.bin
Open HexEditor to modify mbr.bin (Bless Hex Editor, for eg.)
Change from "INS" mode to "OVR" ("Inser" key)
Write "BOOTDISK" starting pos. 0x40 and save.
Copy mbr.bin back to CF
Code: [Select]
~$ sudo dd if=mbr.bin of=/dev/sdb1 bs=512 count=1
Download new firmware, extract and copy to /dev/sdb1

Insert CF in the camera. If the camera is booting from the card the Blue LED will flash.


Related Topics

SimplePortal 2.3.6 © 2008-2014, SimplePortal