Windows GUI for trunk building - page 71 - General Discussion and Assistance - CHDK Forum

Windows GUI for trunk building

  • 771 Replies
  • 230550 Views
*

Offline blackhole

  • *****
  • 844
  • A590IS 101b
    • Planetary astrophotography
Re: Windows GUI for trunk building
« Reply #700 on: 23 / June / 2013, 16:18:20 »
Advertisements
Revision 2895 works well,no more warnings,thanks.

Re: Windows GUI for trunk building
« Reply #701 on: 10 / January / 2014, 18:13:14 »
Hi,
Just got a new Windows 8.1 laptop.  Want to compile CHDK on it, tried installing the shell (343), but get an error when I try to compile:can't find gmake.  Has anyone gotten it to work on Windows 8?  (Hard to search for this, sorry if I missed a discussion)
Jon
Update:got gmake to work (not sure how, but I added it to path, maybe that did it.)  Now as.exe fails
« Last Edit: 10 / January / 2014, 19:23:13 by hiker_jon »

*

Offline fe50

  • ******
  • 3134
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: Windows GUI for trunk building
« Reply #702 on: 11 / January / 2014, 07:33:19 »
Update:got gmake to work (not sure how, but I added it to path, maybe that did it.)  Now as.exe fails
Some thoughts:
- use folders with short (<=8) names without special chars (also no spaces etc.) to avoid problems with windows' roaming & things like that
- run/start as admin, start/run the cmd shell as admin
- play with the windows compatibility setting (e.g. compatibility mode)

To check the environment (e.g. path) settings start the cmd shell from within CHDKSHELL & check them with the "set" command...

Re: Windows GUI for trunk building
« Reply #703 on: 11 / January / 2014, 23:45:50 »
Success!
Not sure what I did.  Tried again today and this time it worked.
There was a message about running in compatibility mode when I first tried.  This time no such message.
Jon


Re: Windows GUI for trunk building
« Reply #704 on: 26 / May / 2014, 17:23:36 »
It looks like the file has been removed from box.net on the first post. Could you please re-upload it?


Thanks!

*

Offline srsa_4c

  • ******
  • 4426
Re: Windows GUI for trunk building
« Reply #705 on: 27 / May / 2014, 15:13:30 »
It looks like the file has been removed from box.net on the first post. Could you please re-upload it?
You can find the full and the update packages here, under "development".

*

Offline lapser

  • *****
  • 1093
Re: Windows GUI for trunk building
« Reply #706 on: 28 / May / 2014, 11:40:05 »
You can find the full and the update packages here, under "development".
Is the latest version there?

I installed "CHDK-Shell-v344-sfx.exe" on a new Windows 8.1 computer and it worked great the first try. Is that the latest version now?

I really appreciate your writing and maintaining this incredible program. Thank you!!!!
EOS-M3_120f / SX50_100b / SX260_101a / G1X_100g / D20_100b
https://www.youtube.com/user/DrLapser/videos

*

Offline srsa_4c

  • ******
  • 4426
Re: Windows GUI for trunk building
« Reply #707 on: 28 / May / 2014, 12:33:25 »
Is the latest version there?

I installed "CHDK-Shell-v344-sfx.exe" on a new Windows 8.1 computer and it worked great the first try. Is that the latest version now?
AFAIK it is, if it's not in that box repo, you can find it here.

Quote
I really appreciate your writing and maintaining this incredible program. Thank you!!!!
The author is whim, not me.


*

Offline lapser

  • *****
  • 1093
Re: Windows GUI for trunk building
« Reply #708 on: 28 / May / 2014, 12:47:35 »
Quote
I really appreciate your writing and maintaining this incredible program. Thank you!!!!
The author is whim, not me.
Oh yeah, thanks Whim!!!!

OK, well thank you for all your great hacking work, and especially for working on Digic 6 now!!!
EOS-M3_120f / SX50_100b / SX260_101a / G1X_100g / D20_100b
https://www.youtube.com/user/DrLapser/videos

*

Offline whim

  • ******
  • 2041
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: Windows GUI for trunk building
« Reply #709 on: 01 / June / 2014, 07:58:08 »
It looks like the file has been removed from box.net on the first post. Could you please re-upload it?


Thanks!

Done - box had deactivated my account, but have restored it now - there was neither warning before, nor explanation afterwards. I checked downloading latest version from the link in the wiki, and it appears to work again.

thanks,
wim
« Last Edit: 01 / June / 2014, 08:27:50 by whim »

 

Related Topics