A810 porting thread - page 8 - DryOS Development - CHDK Forum supplierdeeply

A810 porting thread

  • 106 Replies
  • 30896 Views
Re: A810 porting thread
« Reply #70 on: 09 / November / 2012, 13:15:37 »
Advertisements
Quote
Quote
Another problem I found:  the log files created by various test scripts do not have a proper timestamp -- they are all stamped 01/01/2000.   The ROMLOG.LOG created by CHDK does have the correct timestamp.   Is this somehow related to the os.mkdir giving false failures in the llibtest.lua script?
Did you check the date of your camera? :)   
This is the header of a log file generated by a 100e tester:
Code: [Select]
a810 100e CHDK 1.2.0 Oct 13 2012 13:03:49 dryos 0x323f
START                        |                 PLAY   0 32772 PLY
SET RECORD                   |                    P   2 32772 STL 1480ms sleep 49 OK
TRY                 AUTO   1 |                 AUTO   1 32768 STL   80ms OK
TRY                    P   2 |                    P   2 32772 STL  260ms OK
:P  It's the timestamp on the files -- the creation date, not the time and date reported in the files.   On the camera (using file browser) and on windows, the timestamp gives 01/01/2000, but on a linux box, the timestamps are December 31, 1999:
Code: [Select]
-rwxr-xr-x.  1 root root     75 Dec 31  1999 TSTCALLF.LOG
-rwxr-xr-x.  1 root root   1739 Dec 31  1999 setmode.log
-rwxr-xr-x.  1 root root   7544 Dec 31  1999 paramdmp.log
-rwxr-xr-x.  1 root root   4875 Dec 31  1999 llibtst.log
-rwxr-xr-x.  1 root root    107 Aug  1  2008 vers.req
-rwxr-xr-x.  1 root root    450 Sep  6  2011 changelog.txt
drwx------.  9 root root  32768 Nov  1 14:23 DCIM
drwx------. 16 root root  32768 Nov  1 14:42 CHDK
-rwxr-xr-x.  1 root root   3088 Nov  9 00:17 ROMLOG.LOG
-rwxr-xr-x.  1 root root    403 Nov  9 10:42 buildconf.txt
-rwxr-xr-x.  1 root root 226929 Nov  9 10:43 DISKBOOT.BIN
-rwxr-xr-x.  1 root root  11293 Nov  9 10:43 readme.txt
The 1999 log files were created by lua/bas scripts.  The ROMLOG.LOG with correct timestamp was created when using the CHDK menu option after a crash when debugging the memory issues.

A810 1.00e

Re: A810 porting thread
« Reply #71 on: 09 / November / 2012, 13:42:56 »
Btw, please test this patch to mkdir issue. It was done following the reyalp recommendation posted here.
I have not submitted it, because I want to check the mkdir address better ;)  Maybe that's the problem.
Works.   The two FAILs reported by llibtst.lua on os.mkdir are gone.

I ran llibtst.lua with the cleanup calls (to remove files and directories it creates) commented out.  They all have the same timestamp problem (01/01/00) except for A/MDTST0/TEST1.DAT which is stamped 01/01/84 -- but that is expected since changing the mtime and atime are part of the tests.
A810 1.00e

Re: A810 porting thread
« Reply #72 on: 14 / November / 2012, 15:44:47 »
Hi! I did some tests with the A810. Here are my results with lua scripts over usb:

mode 1 OK
lua shoot() OK
lua play_sound(6) OK
lua while(get_flash_mode()<2) do click("right") end OK
lua while(get_zoom()<3) do click("zoom_in") end OK

lua set_nd_filter(2) OK (tested by overexposing; how do I normally test this one?)

set_iso_real -> seems to be ignored, but does set the right value, correct variable value returned only after shooting!
<conn> luar set_iso_real(50)
script:2
2:ret:nil
<conn> luar get_iso_real()
script:3
3:ret:0 (0)
<conn> luar shoot()
script:4
4:ret:nil
<conn>
unknown command
<conn> luar get_iso_real()
script:5
5:ret:49 (31)

set_iso_mode -> seems to work
<conn> luar get_iso_mode()
script:5
5:ret:1 (1)
<conn> luar set_iso_mode(0)
script:6
6:ret:nil
<conn> luar get_iso_mode()
script:7
7:ret:0 (0)

set_tv96  -> seems to be ignored, but does set the right value, correct variable value returned only after shooting!
<conn> luar get_tv96()           
script:6
6:ret:354 (162)
<conn> luar set_tv96(32)
script:7
7:ret:nil
<conn> luar get_tv96()
script:8
8:ret:354 (162)
<conn> luar shoot()
script:9
luar9:ret:nil
<conn> luar get_tv96()
script:10
10:ret:32 (20)

set_tv96_direct-> seems to be ignored, but does set the right value, correct variable value returned only after shooting!
<conn> luar get_tv96()
script:10
10:ret:32 (20)
<conn> luar set_tv96_direct(16)
script:11
11:ret:nil
<conn> luar get_tv96()
script:12
12:ret:32 (20)
<conn> luar shoot()
script:13
lu13:ret:nil
<conn> luar get_tv96()
script:14
14:ret:16 (10)

Where to start with a A810?
« Reply #73 on: 20 / November / 2012, 11:40:27 »
Hi there,
I thought I followed this thread. But obviously I don't get it.

How can I download "a810-100d-1.2.0-alpha.zip" or something similar to start with?
I saw a lot of patches and everything, but no zip!

I also tried to find something inthe svn... but no 810?

Of course I tried to find an idiots guide to happiness (Howto start,...) but nothing worked for me....
Please help me back on track.

Thanks in advance,
Nightblind


Re: A810 porting thread
« Reply #74 on: 20 / November / 2012, 11:45:41 »
How can I download "a810-100d-1.2.0-alpha.zip" or something similar to start with?
I saw a lot of patches and everything, but no zip!

I also tried to find something inthe svn... but no 810?
http://chdk.wikia.com/wiki/Downloads
http://chdk.wikia.com/wiki/Prepare_your_SD_card

Quote
Of course I tried to find an idiots guide to happiness (Howto start,...) but nothing worked for me....
Please help me back on track.

link> Forum Thread on Getting Started
link> CHDK in Brief
link> CHDK User Quick Start Guide
link> CHDK User Manual
link> CHDK for Dummies
link> CHDK Wiki FAQ
link> CHDK Firmware Usage
link> CHDK Installation Guide
link> One Page Users Guide
Ported :   A1200    SD940   G10    Powershot N    G16

Re: A810 porting thread
« Reply #75 on: 23 / November / 2012, 09:34:32 »
Thanks a lot, Waterwingz, for your fast and intense answer.

If my question made me look only half as stupid as I felt seeing your list of links ...
...  :haha ....
I would dare to come out from behind my rock aroung 2015.

But up 'til then I will try to figure out CHDK.

Thanks again,
Nightblind

Re: A810 porting thread
« Reply #76 on: 23 / November / 2012, 10:24:36 »
If my question made me look only half as stupid as I felt seeing your list of links ...
...  :haha ....
I would dare to come out from behind my rock aroung 2015.
It was a cut&paste response that I use a lot - your question was pretty normal for someone new to CHDK.  Finding the "good stuff" on the wiki and forum is not always easy.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: A810 porting thread
« Reply #77 on: 12 / December / 2012, 21:52:58 »
I think we have a problem with CHDK's Manual Focus functions with the A810 (or I've misunderstood how to use it). 
To use MF, we need to be in <ALT> mode.  If the CHDK help is enabled, you'll see whether MF is on or off -- UP is the toggle.  The help also says DISP sets focus to infinity and DOWN to hyperfocal, which problematic as they are the same button.
How has this been handled on other models?

A810 1.00e


*

Offline Davo

  • ***
  • 176
Re: A810 porting thread
« Reply #78 on: 15 / January / 2013, 07:50:54 »
Hi all from the latest noobie!

I just bought my A810 from Argos for £50 after reading about CHDK while doing a search for fast shutter cameras. I couldn't believe the feature set that was promised but I thought I would give it a try. Anyhoos, I now have 1.00e installed and I am blown away. My interests are astro, birds, HDR and focus stacking and I can't wait to try out all the features.

Some notes that may help other A810 noobies.

1. I used ACID to identify the firmware version.

2. You only need to touch the Play (>) button briefly to enable the ALt mode. I was pressing for too long and switching the camera off at first.

3. I tried a battery endurance test with the standard intervalometer script and 15s intervals. Fully charged Philips 2450mah batteries lasted for 3h50m and captured 950 full size shots (no flash).

Many thanks to the developers for all their hard work. I do a bit of coding myself so please let me know if I can help with testing.

Dave

ps I have a Zigview motion detecting intervalometer for my DSLR which cost me ~£200. My A810 now has the same for free and I can even script my own routines for it. Am I chuffed or what?

Re: A810 porting thread
« Reply #79 on: 15 / January / 2013, 09:55:28 »
2. You only need to touch the Play (>) button briefly to enable the ALt mode. I was pressing for too long and switching the camera off at first.
FWIW - this is the normal action when CHDK "shares" a button with the camera firmware.  A brief press triggers CHDK <ALT> mode and a longer press ( about 1 second ) triggers the original camera functionality.   In your case, the original functionality is to go into playback mode if you are in shooting mode or to switch off if you are in playback mode.

Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics