A810 porting thread - page 2 - DryOS Development - CHDK Forum

A810 porting thread

  • 106 Replies
  • 37472 Views
Re: A810 porting thread
« Reply #10 on: 30 / August / 2012, 11:58:53 »
Advertisements
I have 100d so I ask you:
a810-100d-1.2.0-prealpha-r1.zip
is fixed as
a810-100b-1.2.0-prealpha-r4.zip?


Thank you nafraf

*

Offline nafraf

  • *****
  • 1308
Re: A810 porting thread
« Reply #11 on: 30 / August / 2012, 13:04:38 »
I have 100d so I ask you:
a810-100d-1.2.0-prealpha-r1.zip
is fixed as
a810-100b-1.2.0-prealpha-r4.zip?
No, a810-100b-xxxxx is only valid for firmware version 100b

a810-100d-xxxxx is only valid for firmware version 100d.    Only this files will work on your camera. 


In a few days I'll post a new version for 100d.

« Last Edit: 30 / August / 2012, 13:07:21 by nafraf »

*

Offline nafraf

  • *****
  • 1308
Re: A810 porting thread
« Reply #12 on: 31 / August / 2012, 01:55:36 »
alpha version for 100b and 100d was published at top of this thread.

* Optical zoom during video recording and Video quality were added.
* Every thing should work.

Known bugs:
* AF Scan during video recording is not implemented
* mkdir function using chdkptp returns error
* Grid in Connect4 is not visible.

Please test and report if any problem is detected.

EDIT
  • Camera crashes if GetBatteryTemperature called
« Last Edit: 04 / September / 2012, 15:58:36 by nafraf »

Re: A810 porting thread
« Reply #13 on: 01 / September / 2012, 09:38:34 »
Thank you nafraf


Re: A810 porting thread
« Reply #14 on: 01 / September / 2012, 20:01:07 »
Hello nafraf
I downloaded your a810-100d alpha  software posted yesterday and installed it on my SD Card and tried it on my PowerShot A1300 and I suspect the porting & firmware are both the same Cameras only the A1300 has one upgrade from the A810 an optical viewfinder. I find the software also boots up and loads on my a1300. My A1300 has the same 100d version no so I guess both cameras are the same except for the Optical Viewfinder on my A1300 which makes it a very nice Camera. I havn't had too much time to play with the software there is a few minor glitches with the OSD on the main menu the framing square wipes out the letters and you move around the focus Square through they come back. If you need a firmware dump If I know a little more what I was doing I could get a firmware dump from my Camera. I hope that helps thanks very much nafraf
Regards
Gerry

*

Offline nafraf

  • *****
  • 1308
Re: A810 porting thread
« Reply #15 on: 01 / September / 2012, 20:08:50 »
Hello nafraf
I downloaded your a810-100d alpha  software posted yesterday and installed it on my SD Card and tried it on my PowerShot A1300 and I suspect the porting & firmware are both the same Cameras only the A1300 has one upgrade from the A810 an optical viewfinder. I find the software also boots up and loads on my a1300. ..
Hello Gerry, That's too weird, but it's very interesting :)  I'd like to have access to the a1300 firmware dump to compare both.

Here you can find information for firmware dump:  http://chdk.wikia.com/wiki/Canon_Basic/Scripts/Dumper
Thanks
« Last Edit: 01 / September / 2012, 20:10:50 by nafraf »

Re: A810 porting thread
« Reply #16 on: 02 / September / 2012, 14:42:20 »
Hello nafraf
I went to that scripting page and I see a lot of text I don't really understand how do I get the firmware dump done on my new A1300. I already tried Cardtricks software it did not work for me. Did you have to use the blinker Nafraf? Can you add a few simple files to the SD Card and get a dump. How did you get the dump out of your a810. I might have made a great discovery Canon uses the same firmware in more than 1 camera.
73 Best Regards in Ham Lingo
Gerry VE7BGP

*

Offline nafraf

  • *****
  • 1308
Re: A810 porting thread
« Reply #17 on: 02 / September / 2012, 16:00:47 »
Hello nafraf
I went to that scripting page and I see a lot of text I don't really understand how do I get the firmware dump done on my new A1300. I already tried Cardtricks software it did not work for me. Did you have to use the blinker Nafraf? Can you add a few simple files to the SD Card and get a dump.
You don't need any blinker,  it's possible to do the firmware dump using only a SD-CARD and the dumper script.

First, SD-Card should be prepared for running dump script. After that and you need to copy  the code of  universal dumper script to a file named "extend.m", in sd-card.  Then turn on the cam with PLAY button and press FUNC.

Detailed instructions for prepare SD-Card are in overview section of http://chdk.wikia.com/wiki/Canon_Basic/Card_Setup.
If you are using windows, check instructions using EOSCard and ignore scripts in CHDK and *nix section.

Quote
I might have made a great discovery Canon uses the same firmware in more than 1 camera.
Similar case was seen with sx240hs and sx260hs models.


Re: A810 porting thread
« Reply #18 on: 02 / September / 2012, 16:24:37 »
You don't need any blinker,  it's possible to do the firmware dump using only a SD-CARD and the dumper script.
First, SD-Card should be prepared for running dump script. After that and you need to copy  the code of  universal dumper script to a file named "extend.m", in sd-card.  Then turn on the cam with PLAY button and press FUNC.
Detailed instructions for prepare SD-Card are in overview section of http://chdk.wikia.com/wiki/Canon_Basic/Card_Setup.
If you are using windows, check instructions using EOSCard and ignore scripts in CHDK and *nix section.
One small caution - sometimes the font color used with the Universal Dumper script does not show up on the LCD so it will look like nothing happens when you press the FUNC button.   Check the SD card for the PRIMARY.BIN file - it might be there even though nothing showed on the screen.

« Last Edit: 02 / September / 2012, 16:26:30 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline nafraf

  • *****
  • 1308
Re: A810 porting thread
« Reply #19 on: 09 / September / 2012, 19:12:18 »
Finally, AF during video recording is working.

I used this hint:
Great news, I found a way to solve the AF Scan crash. I used DoAFLock() instead of MakeAFScan(). I was experimenting with UnlockAF after MakeAFScan to see what happens and tried also DoAFLock and found it. Look like it has the same functionality and doesn't crash when zooming.

I added an entry in stubs_entry_2.S with name MakeAFScan but using DoAFLock address.  Is it OK? or do you recommend other workaround?



 

Related Topics