S95 installation issues - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum supplierdeeply

S95 installation issues

  • 2 Replies
  • 1551 Views
S95 installation issues
« on: 12 / August / 2012, 14:38:46 »
Advertisements
Hello,

This is my first time using CHDK, and I'm having a few problems with installation that I was hoping someone could help me to troubleshoot.

Short version: Camera does not show CHDK menu; raw, bracketing options show up even when using SD card without CHDK.

Long version:
I have a Powershot S95 with firmware version 1.00k. I downloaded the archive s95-100k-1.1.0-2033-full_BETA.zip, bought a fresh 32gb SD card, prepared the card using LICKS with two partitions using whatever it decided should be the default settings (except that I also instructed it to copy the contents of the directory where I unzipped chdk to the card).

I put the new SD card in my camera (neglecting to set the lock switch on the card) and turned it on. It showed a number of new menu options, including raw images and bracketing. However, the CHDK splash screen did not display, and a number of the other menu options that are described on the wiki are not present. (E.g. the CHDK menu.) It also reported that there was no space available on the card. I read somewhere in the forums that someone had to name the second partition CANON to be able to write images to it. So I re-prepared the card using LICKS with that partition name, and I was able to take pictures. (Again, having neglected to set the lock switch.)

Later I would try to figure out what was going on with the menus, and when I stuck the card into my laptop and tried to list the contents, it hung up the machine. (I couldn't even 'kill -9' the process.) I subsequently realized I hadn't locked the SD card, and figured I'd messed something up by doing that. So I put in my old SD card without CHDK, but when I turned on the camera, it still showed the raw and bracketing menu options.

I tried re-preparing the SD card again, and turning on the lock switch, but I didn't get the CHDK menu.

I have two questions:
1) I think I am missing something obvious and crucial step (and that I probably missed in the manual) about the install that is causing the camera to not show the splash screen and CHDK menu. Has anyone else had this experience and point me in the right direction?
2) I thought that if I kept CHDK on the SD card it wouldn't permanently change the firmware (I didn't use the update firm option). Did I misread something, or is my camera behaving strangely?

Many thanks in advance!

Re: S95 installation issues
« Reply #1 on: 12 / August / 2012, 14:44:59 »
1) I think I am missing something obvious and crucial step (and that I probably missed in the manual) about the install that is causing the camera to not show the splash screen and CHDK menu. Has anyone else had this experience and point me in the right direction?
You have to either boot CHDK with :
1) The firmware update method using the Canon menus
or
2) The SD card lock method - and the SD card lock has to be set for this to happend.

Note that when extracting the CHDK zip file to a dual partition card,  the diskboot.bin and ps.fi2 files go on the smaller FAT16 partition.  Everything else goes onto the larger FAT32 partition.

More detailed description here : 

link> Prepare Your SD Card

Quote
2) I thought that if I kept CHDK on the SD card it wouldn't permanently change the firmware (I didn't use the update firm option). Did I misread something, or is my camera behaving strangely?
I think you are seeing Canon's build in RAW and bracketing functions. Doesn't sound like you have ever actually loaded CHDK and you are right - it would not make permanent changes - regardless of which of the two booting methods you used !
Ported :   A1200    SD940   G10    Powershot N    G16

Re: S95 installation issues
« Reply #2 on: 13 / August / 2012, 10:32:42 »
Thanks Waterwingz!

Everything seems to be working.

 

Related Topics