Build 48 - page 2 - AllBest's Builds - CHDK Forum  

Build 48

  • 49 Replies
  • 34325 Views
*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: Build 48
« Reply #10 on: 28 / March / 2008, 05:07:01 »
Advertisements
well nothing in the custom auto iso works on my A710. ewavr, what about yours?

I did not test custom autoiso.

ISO overrides never worked and don't work here either.
Yes.
But I don't need autoiso. I always set ISO80 (as a last resort ISO200).

*

Offline mkmenuts

  • **
  • 61
  • SD700 (1.01b)
Re: Build 48
« Reply #11 on: 28 / March / 2008, 05:13:13 »
there is some kind of bug in autoiso mode in my bulid...
A630 build 48
minimal shutter speed: auto
min iso: 5
max iso:30
max isohi:53
user factor:1
is factor:1
no zoom

and i get as target shutter speed 1/80s (or 1/60) in both auto iso mode...
1/80 isn't too high for user factor 1?
The User mode calculates the slowest shutter speed, perhaps the scene has lots of light, so your ISO was put to the minimum (and faster shutter used)? The Custom AutoISO tries to maintain the same overall exposure...

Quote
when using zoom, target sutter speed changes like expected
Great!

Quote
IS factor doesn't affect anything at all(because i got no IS?)so it should be removed, or make it work...
For camera's w/o IS it is simply ignored (defaults to 1).
Quote
i think it's using 1/(FL*10*user) for shutter speed calculations.
It should use 1/(FL*user_factor)*is_factor, but this is only the slowest recommended setting.
Quote
minimal shutter speed works ok (user factor is ignored)
Good to know, at least the problem is localized.

Thanks dzsemx for your testing and reporting, I will collect more info and correct as needed. Please note the ISO for each selected shutter speed to see if you hit the max/min values you set.

*

Offline mkmenuts

  • **
  • 61
  • SD700 (1.01b)
Re: Build 48
« Reply #12 on: 28 / March / 2008, 05:17:03 »
But I don't need autoiso. I always set ISO80 (as a last resort ISO200).
Ewavr,

I also like using ISO 80, but here there's a chance to get even better dynamic range and lower noise by setting the range 50-200 (or whatever number is the true base ISO for your camera).

The difference from the previous setting is that custom AutoISO maintains the same exposure.

mkmenuts

*

Offline ewavr

  • ****
  • 1057
  • A710IS
Re: Build 48
« Reply #13 on: 28 / March / 2008, 05:24:49 »

I also like using ISO 80, but here there's a chance to get even better dynamic range and lower noise by setting the range 50-200 (or whatever number is the true base ISO for your camera).

The difference from the previous setting is that custom AutoISO maintains the same exposure.


But A710 don't support ISO override, except standart values (80, 100, 200, 400, 800).


*

Offline a710is

  • ****
  • 250
  • A710 IS
Re: Build 48
« Reply #14 on: 28 / March / 2008, 05:48:55 »
I think the A710 does support ISO override but it's not well implemented for it.
when you set an ISO override and take a picture you do get the result you had wanted on screen when you let go of the shutter button immediately after taking the pic. the camera just overrides the ISO in the wrong phase.

Re: Build 48
« Reply #15 on: 28 / March / 2008, 05:51:02 »
ewavr  
Quote
But A710 don't support ISO override, except standart values (80, 100, 200, 400, 800)
Realy so? Can you test it by using some of this algorithms (at least for clearness concerning a710)
SD1000 ISO Settings Error

« Last Edit: 28 / March / 2008, 06:05:21 by Allbest »

Re: Build 48
« Reply #16 on: 28 / March / 2008, 06:02:03 »
minimal shutter speed doesn't work either
Minimal shutter speed is only one parameter of algorithm. It is desirable value but it doesn't set directly. It depends from current exposure, Max and min iso settings
ISO overrides never worked and don't work here either.
Did you test iso override in Auto ISO mode?
the camera just overrides the ISO in the wrong phase
May be but all overrides CHDK does in one phase

*

Offline a710is

  • ****
  • 250
  • A710 IS
Re: Build 48
« Reply #17 on: 28 / March / 2008, 06:32:46 »
Quote
Did you test iso override in Auto ISO mode?

I did, it only affects the screen image as usual, when I release the shutter after pressing it.


Re: Build 48
« Reply #18 on: 28 / March / 2008, 09:49:26 »
Hello,
thanks for the great work.
One feature I think a lot of people are waiting for is the "delete RAW when you delete JPG". I think people were working on it.
Will anybody be able to include it soon?

Thanks!
obitus

*

Offline PhyrePhoX

  • *****
  • 2254
  • make RAW not WAR
    • PhyreWorX
Re: Build 48
« Reply #19 on: 28 / March / 2008, 10:13:32 »
wontolla ("maintainer of that feature") is working on it, and he will take the time that is needed. As he is busy with other things right now, it can take a while for that (great) feature to be implemented. you can however compile your own flavor of chdk with wontollas code included (if you know how to use a compiler and a text editor).

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal