SX30IS issues... - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum  

SX30IS issues...

  • 9 Replies
  • 2131 Views
SX30IS issues...
« on: 24 / September / 2012, 19:47:36 »
Advertisements
SX30IS version "GM1.00L" of the firmware.

Issues:

- unable to make the "make card bootable" work.  I can reload the firmware each time, but that's quite a pain.  The process as described in the readme and instructions seems to work, but the result is base software any time I power the camera off and back on.

- The instructions state to go through the "make card bootable" process, then pull the card out and lock it for write.  When I open the door to remove the card, the camera powers off.  When I set the card to write-protect, reinsert it, power the camera back up, it basically wont do squat except display that the card is write protected.

Help with these two issues would be appreciated.

Constructive criticism:  The instructions in the readme are wrong.  It states:

- If you would like to have CHDK auto-load every time you power on
your camera, then go into CHDK's menu system. (Press "Shortcut" to enter <ALT>
mode, then your "Menu" button to enter CHDK's menus.) Scroll to the bottom
of the main CHDK menu to the "Debug Parameters" option.
- Enter the "Debug" menu and scroll to "Make Card Bootable...". Press your "Set" button.


The "make card bootable is not under "debug parameters" but under miscellaneous.

Re: SX30IS issues...
« Reply #1 on: 24 / September / 2012, 19:53:57 »
SX30IS version "GM1.00L" of the firmware.
Fully supported version .. this is good.

Quote
Issues:
- unable to make the "make card bootable" work.  I can reload the firmware each time, but that's quite a pain.  The process as described in the readme and instructions seems to work, but the result is base software any time I power the camera off and back on.
- The instructions state to go through the "make card bootable" process, then pull the card out and lock it for write.  When I open the door to remove the card, the camera powers off.  When I set the card to write-protect, reinsert it, power the camera back up, it basically wont do squat except display that the card is write protected.
Help with these two issues would be appreciated.
You really need to read, understand, and follow the instructions here : http://chdk.wikia.com/wiki/Prepare_your_SD_card

A few people spent a lot of time on the instructions you will find there. They cover a very broad range of cameras and needs.  Let us know what doesn't work for you there ?

Quote
Constructive criticism:  The instructions in the readme are wrong.
Yup.  One more things for the huge group of lazy paid CHDK staffers to fix.  Except there are no staffers - lazy or otherwise.  Still,  this has come up enough that the limited staff of not-too-bright volunteers might be able to fix it.

Ported :   A1200    SD940   G10    Powershot N    G16

Re: SX30IS issues...
« Reply #2 on: 24 / September / 2012, 20:03:42 »
You really need to read, understand, and follow the instructions here : http://chdk.wikia.com/wiki/Prepare_your_SD_card

A few people spent a lot of time on the instructions you will find there. They cover a very broad range of cameras and needs.  Let us know what doesn't work for you there ?

OK, will go through the whole process for about the 5th time and confirm.
Yup.  One more things for the huge group of lazy paid CHDK staffers to fix.  Except there are no staffers - lazy or otherwise.  Still,  this has come up enough that the limited staff of not-too-bright volunteers might be able to fix it.

I fully grok the issues of open source.  I dont mind rewriting the thing if someone will tell me how to resubmit it for consideration.

Re: SX30IS issues...
« Reply #3 on: 24 / September / 2012, 20:10:33 »
I fully grok the issues of open source.  I dont mind rewriting the thing if someone will tell me how to resubmit it for consideration.
Sorry.  I guess I should not try to be "funny" in my posts. 

What instructions were you trying to follow ?  The ones in the wiki page I posted ?  Or the "readme.txt" file that comes with CHDK ?   Its really out of date and way too generic .. some of the steps there are just plain wrong for today's cameras.

Tell us what steps you took as you worked through it.   Trust me,  thousands of people have made this work - the failure must be in something unclear in our documentation.

But that's what the H in CHDK stands for ... you've come to the right place for more help.


UPDATE 1 : time to update the readme.txt file I guess .. been a while.  There is a volunteer that usually gets sucked into those update ... I'll ask him the next time I see him.
I dont mind rewriting the thing if someone will tell me how to resubmit it for consideration.
I'm sure our volunteer "rewriter" will not stand in your way.  You could even start a new thread on this forum and post your rewrite there ?

UPDATE 2 :   I'm going to continue to try to be funny.

« Last Edit: 24 / September / 2012, 20:17:51 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16


Re: SX30IS issues...
« Reply #4 on: 24 / September / 2012, 21:38:26 »
virustotal says eoscard.exe is a virus.  Admittedly, only one hit out of a bunch of antivirus engines, but stilll...
https://www.virustotal.com/file/f9f73eaa82c170cfa7b9289b23d62c07988810bc8c7ce1600320a6c2e8973bd5/analysis/

The first method in the detailed wiki instructions didnt work.  Im starting on the second set.

Re: SX30IS issues...
« Reply #5 on: 24 / September / 2012, 21:58:21 »
virustotal says eoscard.exe is a virus.  Admittedly, only one hit out of a bunch of antivirus engines, but stilll...
https://www.virustotal.com/file/f9f73eaa82c170cfa7b9289b23d62c07988810bc8c7ce1600320a6c2e8973bd5/analysis/
False positives are not unusual.  I'm sure kingsoft is a reliable scanner even though I have never heard of it and all the scanners I trust don't get that result.  And if its true,  all my machines must be infected  - even though none of the five scanners I run from day to day have picked it up

Quote
The first method in the detailed wiki instructions didnt work.  Im starting on the second set.
Could you be more specific please ? Which first method ?
« Last Edit: 24 / September / 2012, 22:01:45 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: SX30IS issues...
« Reply #6 on: 24 / September / 2012, 22:01:54 »
Method # 2 doesnt work either.  Camera still comes up with "memory card locked" and wont do anything.  CHDK isnt not loaded on startup.

I tried a 2GB card, and it seems to work using method 1.  Apparently this camera doesnt like the MBR on a FAT32 partition.

Re: SX30IS issues...
« Reply #7 on: 24 / September / 2012, 22:05:18 »
Could you be more specific please ? Which first method ?

Here: http://chdk.wikia.com/wiki/Prepare_your_SD_card under the section "Bootable SD Card Method Preparation" it shows method 1 and 2.  Neither method worked for the 8GB card, and method 2 did not work for the 2GB card (formatted at fat16) but method 1 *did* work.  Camera nows powers up with a locked card into CHDK.  I dont like this because I cant use the larger card capacity, but for what I want to do it may work.


Re: SX30IS issues...
« Reply #8 on: 24 / September / 2012, 22:05:54 »
I tried a 2GB card, and it seems to work using method 1.  Apparently this camera doesnt like the MBR on a FAT32 partition.
So I guess you missed the part at the top of that page ... where it tells you that you need to know when your camera was released ... in a BIG BOLD TEXT box .. ???

Your camera was released in 2010.   It will not support FAT 32 booting.   It says that many times on the page.

You need to either use a 4G or less card formatted FAT 16 or use the instructions for dual paritition booting.  That will get you the ability to use a larger capacity card.   Just like it says on that page.



« Last Edit: 24 / September / 2012, 22:08:31 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: SX30IS issues...
« Reply #9 on: 24 / September / 2012, 23:08:02 »
Your camera was released in 2010.   It will not support FAT 32 booting.   It says that many times on the page.
Thanks

 

Related Topics