CHDK for G12 just...not working :( - General Help and Assistance on using CHDK stable releases - CHDK Forum
supplierdeeply

CHDK for G12 just...not working :(

  • 11 Replies
  • 2374 Views
CHDK for G12 just...not working :(
« on: 26 / September / 2012, 00:03:57 »
Advertisements
Hi all, I want to try out CHDK on my G12 with a particular view of getting longer exposures. I downloaded g12-100g-1.1.0-2174 full and unzipped it onto the SD card. I then put it in my camera and pressed play then set and Disp. The display showed up as expected. I went to Firm update and confirmed I wanted to upgrade to 1.1.0. It then went black and the little green power light was all I saw. In the end I had to pull the battery. What am I doing wrong and can you help me to make it right? I also tried g12-100f full and g12-100g small with the same results. Sad!

Hope someone can help.

Phil

*

Offline zeno

  • *****
  • 889
Re: CHDK for G12 just...not working :(
« Reply #1 on: 26 / September / 2012, 04:07:36 »
There's no point in trying alternative builds - you have to find out what firmware version your camera has. The simple way is to use my Acid app (runs on Windows, Linux and Mac OSX) whihc will download the right build for you. See http://www.zenoshrdlu.com/acid/acid.html
A570, S100, Ixus 127
Author of ASSIST, STICK, WASP, ACID, SDMInst, LICKS, WICKS, MacBoot, UBDB, CFGEdit

Re: CHDK for G12 just...not working :(
« Reply #2 on: 26 / September / 2012, 12:18:35 »
Success! Wonderful. Thanks so much. Now I have to work out how to make it show me long exposures. Off to look at help files.
Phil

Re: CHDK for G12 just...not working :(
« Reply #3 on: 26 / September / 2012, 12:28:03 »
OK. I'm stumped again. Long exposures of up to 60 seconds or whatever is really the only aspect of CHDK that I want to use but also the only aspect I cannot find any info on using and cannot find on the camera looking through the menus etc. Can you help point out how to make that happen and then I promise to be happy!

Thanks for your continued help.

Phil


*

Offline Pier

  • ***
  • 128
Re: CHDK for G12 just...not working :(
« Reply #4 on: 26 / September / 2012, 13:42:18 »
I'm not owner of G12, but think for all Cams it is equal... to say:
-Press appropriate key for Alt mode, go to Menu:
-Extra Photo Operations-->Enable Overrides.
-Override Shuter Speed --> Set to 60
-Value Factor - set to --> 1
-Shutterspeed enum type --> Set to Ev Step
Thats all.
Go to http://images3.wikia.nocookie.net/__cb20120105020429/chdk/images/6/62/CHDK_User_Quick_Start_Guide.pdf
and download.

Re: CHDK for G12 just...not working :(
« Reply #5 on: 12 / October / 2012, 16:52:30 »
Hi there,
Similar problem to OP but my problem with CHDK is that I can't access <ALT> mode at all.
I can sucessfully update the firmware to 1.1.0.0, and the CHDK splash screen pops up. However after that when in rec mode, no matter what button(s) I press, i'm just not able to get into <ALT> mode. I see from the manual/wiki that the normal button is [SHORTCUT] but, as OP says, it's just...not working :(.

I've downloaded the correct firmware (1.00e) and the G12 is from 2010 so the SD card has been formatted correctly using CardTricks.

An interesting thing that happens is if I go into rec mode then back into play mode and try get into rec mode again (via depressing the shutter) a number appears in the top right corner, counting upwards as long as I depress the shutter.

Whilst I'm in REC mode, I can't access any other menus nor take a picture.

Anyone have any idea what is going wrong?
Many thanks!



Re: CHDK for G12 just...not working :(
« Reply #6 on: 12 / October / 2012, 17:05:36 »
I see from the manual/wiki that the normal button is [SHORTCUT] but, as OP says, it's just...not working :(.

Anyone have any idea what is going wrong?
Try the Print button - the one on the left with the Blue lamp in it.

Ported :   A1200    SD940   G10    Powershot N    G16

Re: CHDK for G12 just...not working :(
« Reply #7 on: 12 / October / 2012, 17:19:57 »
Hi waterwingz, thanks for the quick reply. .
The print button doesn't respond (the print button is the same button as the [shortcut] button - top left button above the LCD) whilst CHDK is running.
« Last Edit: 12 / October / 2012, 17:22:52 by thomas.gurney.18 »


*

Offline msl

  • *****
  • 1271
  • A720 IS, SX220 HS 1.01a
    • CHDK-DE links
Re: CHDK for G12 just...not working :(
« Reply #8 on: 12 / October / 2012, 17:54:12 »
The same issue was reported in German forum, G12 100e ALT button without function. It is not quite clear whether the error occurs in both versions (1.1 & 1.2) or only in version 1.2.

msl
CHDK-DE:  CHDK-DE links

*

Offline philmoz

  • *****
  • 3179
    • Photos
Re: CHDK for G12 just...not working :(
« Reply #9 on: 12 / October / 2012, 20:16:55 »
Hi there,
Similar problem to OP but my problem with CHDK is that I can't access <ALT> mode at all.
I can sucessfully update the firmware to 1.1.0.0, and the CHDK splash screen pops up. However after that when in rec mode, no matter what button(s) I press, i'm just not able to get into <ALT> mode. I see from the manual/wiki that the normal button is [SHORTCUT] but, as OP says, it's just...not working :(.

The same issue was reported in German forum, G12 100e ALT button without function. It is not quite clear whether the error occurs in both versions (1.1 & 1.2) or only in version 1.2.

msl

This was only happening in release-1.1 (not 1.2) and came from revision 2201 where I merged some changes from 1.2 back to 1.1; but missed one change.

Should be fixed in revision 2207 which will be in the autobuild server in the next few hours.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)

 

Related Topics