A450 1.00D porting - General Discussion and Assistance - CHDK Forum

A450 1.00D porting

  • 21 Replies
  • 11433 Views
*

Offline brabl2

  • *
  • 31
  • A710IS
A450 1.00D porting
« on: 27 / March / 2008, 15:40:26 »
Advertisements
Hi,
Here are first pre-alpha CHDK binaries for A450-1.00D
zSHARE - a450-100d-bin.zip
I have not access to any A450 device, so it is completely untested.
I believe it will work ;)
A450 firmware is almost identical to A460 which was already succesfully ported.
It is based on trunk-r348.
All CHDK features should be working except "Video parameters" setting (not implemented yet)

Your feedback is welcome!

Pavel
« Last Edit: 09 / April / 2008, 15:26:03 by brabl2 »

Re: A450 1.00D porting
« Reply #1 on: 27 / March / 2008, 22:04:17 »
Hi,
Here are first pre-alpha CHDK binaries for A450-1.00D
zSHARE - a450-100d-bin.zip
I have not access to any A450 device, so it is completely untested.
I believe it will work ;)
A450 firmware is almost identical to A460 which was already succesfully ported.
It is based on trunk-r348.
All CHDK features should be working except "Video parameters" setting (not implemented yet)

Your feedback is welcome!

Pavel

Thanks Pavel!
Thanks for your build!

but my A450 in Canon for repair right now(Due to the Lens Problem and near the end of the warranty  :lol )
hope they will not update my firmware  :o

When i get back the A450(Usually only need 3-5 days), i will check the firmware version again and try your build  :P

Thanks for your build again!

mp9_sit

Re: A450 1.00D porting
« Reply #2 on: 08 / April / 2008, 22:18:52 »
Hi,
Here are first pre-alpha CHDK binaries for A450-1.00D
zSHARE - a450-100d-bin.zip
I have not access to any A450 device, so it is completely untested.
I believe it will work ;)
A450 firmware is almost identical to A460 which was already succesfully ported.
It is based on trunk-r348.
All CHDK features should be working except "Video parameters" setting (not implemented yet)

Your feedback is welcome!

Pavel

Sorry For my late reply. i've just get back the DC i'm testing it now. :D

This Release is work fine in A450-1.00D! Thx A lot brabl2 :lol

I can suggest if the CHDK can add the apature control in the Low-end A series will be a good features  :D
« Last Edit: 08 / April / 2008, 23:31:32 by mp9_sit »

*

Offline brabl2

  • *
  • 31
  • A710IS
Re: A450 1.00D porting
« Reply #3 on: 09 / April / 2008, 02:45:24 »
This Release is work fine in A450-1.00D! Thx A lot brabl2
Sounds good !
I will add "Video parameters" setting (movie_rec.c) and then it will be ready for adding into trunk :)

Quote
I can suggest if the CHDK can add the apature control in the Low-end A series will be a good features
A450 (like other low cost cameras) has no Iris diaphragm physically.
Aperture is fixed to Focal length, so aperture control is not possible.
However it has ND-filter feature. You can use corresponding CHDK menu entry to enable or disable ND-filter.

I have one question:
At the bottom of the display there is Av value shown when Shoot button is half-pressed.
Is it identical (for all zoom steps) to Av value shown in EXIF info?

Pavel


Re: A450 1.00D porting
« Reply #4 on: 09 / April / 2008, 05:20:24 »
At the bottom of the display there is Av value shown when Shoot button is half-pressed.
Is it identical (for all zoom steps) to Av value shown in EXIF info?
it was 5.4/6.8/8.1/9.8/11.8/14.4/17.6 i should be correct :D

A450 (like other low cost cameras) has no Iris diaphragm physically.
Aperture is fixed to Focal length, so aperture control is not possible.

I think The A450 have the iris! Because i have try to use the Fireworks mode in A450 CHDK shown
 Av:7.85 in the LCD display
when i have zoom to 17.6mm it show Av:13.55
and i saw inside the lens have some different
(I don't know how to tell maybe i try to take some pic when i back home :P)
(I have uploaded a picture using fireworks mode notice the F number in the EXIF)


another question when i'm using the "Extra Photo Operations" Override some stting Like "ISO" shutter
the metering system haven't use the override setting. is it normal?

« Last Edit: 09 / April / 2008, 05:26:01 by mp9_sit »

*

Offline brabl2

  • *
  • 31
  • A710IS
Re: A450 1.00D porting
« Reply #5 on: 09 / April / 2008, 07:09:32 »
I think The A450 have the iris! Because i have try to use the Fireworks mode in A450 CHDK shown Av:7.85 in the LCD display
when i have zoom to 17.6mm it show Av:13.55
and i saw inside the lens have some different
(I don't know how to tell maybe i try to take some pic when i back home)
(I have uploaded a picture using fireworks mode notice the F number in the EXIF)

Hmm...then...ND-filter is probably used in "Fireworks mode"  :)
When you look at your sensor throught lenses, do you see moving iris or just ND filter covering and uncovering the sensor?
Just try to Put In/Out ND filter in "Extra Photo Operations" and you will see..
The F (Av) number is somehow enumerated from focal length and ND filter presence for A460.
And I believe this way it works also in A450.
F-numbers (all zoom steps) for A460 are:
ND-filter out: 2.8 3.2 3.5 3.5 4.0 4.5 5.0 5.8
ND-filter in  : 8.0 9.0 10.0 10.0 11.0 13.0 16.0 18.0

Could you provide F-numbers for all zoom steps from EXIF in "Fireworks mode" (probably in range 8.0 to 16.0)


Another question is: Do you see CHDK shutter speed at the bottom of LCD display?
It should look this way: 1/60" F2.8
or do you see 1/60" F?
If you see '?' then it needs to be fixed.


Quote
another question when i'm using the "Extra Photo Operations" Override some stting Like "ISO" shutter
the metering system haven't use the override setting. is it normal?
Hmm...this is probably correct behaviour.
The metering system of my A710IS also doesn't care about "ISO override"

Pavel

Re: A450 1.00D porting
« Reply #6 on: 09 / April / 2008, 08:14:00 »
Quote
Hmm...then...ND-filter is probably used in "Fireworks mode"  Smiley
When you look at your sensor throught lenses, do you see moving iris or just ND filter covering and uncovering the sensor?
Just try to Put In/Out ND filter in "Extra Photo Operations" and you will see..
The F (Av) number is somehow enumerated from focal length and ND filter presence for A460.
And I believe this way it works also in A450.
F-numbers (all zoom steps) for A460 are:
ND-filter out: 2.8 3.2 3.5 3.5 4.0 4.5 5.0 5.8
ND-filter in  : 8.0 9.0 10.0 10.0 11.0 13.0 16.0 18.0

Could you provide F-numbers for all zoom steps from EXIF in "Fireworks mode" (probably in range 8.0 to 16.0)

the F-Number for all zoom step 7.85/8.41/9.04/9.82/10.83/11.98/13.55

And I have uploaded the Photo For your reference

I found that it is ND Filter I try to put in the ND filter. have same result in the Lens

Quote
Another question is: Do you see CHDK shutter speed at the bottom of LCD display?
It should look this way: 1/60" F2.8
or do you see 1/60" F?
If you see '?' then it needs to be fixed.

Yes there is 2" F?
« Last Edit: 09 / April / 2008, 08:19:05 by mp9_sit »

*

Offline brabl2

  • *
  • 31
  • A710IS
Re: A450 1.00D porting
« Reply #7 on: 09 / April / 2008, 14:42:41 »
Here are (hopefully) final CHDK binaries for A450-1.00D
zSHARE - a450-100d-bin.zip
- added "Video params" setting

It is based on trunk-r375.
I hope there will be no problems, so this release could be added into the trunk.

Pavel


Re: A450 1.00D porting
« Reply #8 on: 09 / April / 2008, 21:31:25 »
Here are (hopefully) final CHDK binaries for A450-1.00D
zSHARE - a450-100d-bin.zip
- added "Video params" setting

It is based on trunk-r375.
I hope there will be no problems, so this release could be added into the trunk.

Pavel
The release is ok at all, but have some little problems
1.  if the video quality set to 99 the cam will be hang. Maybe due to my SD card is too slow(Toshiba 1G Class4)
2. The Menu will be suddenly disappear, when u press the up/down key the menu will be back (Last build haven't found this problem)

but now added the "Video params" and "Custom Auto ISO" is great  :xmas

and the F-Number us correct showing when the ND in :P

Thx Pavel :D


*

Offline brabl2

  • *
  • 31
  • A710IS
Re: A450 1.00D porting
« Reply #9 on: 10 / April / 2008, 02:04:05 »
1.  if the video quality set to 99 the cam will be hang. Maybe due to my SD card is too slow(Toshiba 1G Class4)
It looks that you need to find limits of you SD card.
Have you tried to change 'Video bitrate' instead of 'Video quality'?
More about Video settings here: CHDK firmware usage - CHDK Wiki

You can try run "Debug params/Benchmark" for your SD card and compare it to this list Benchmarks - CHDK Wiki

Quote
2. The Menu will be suddenly disappear, when u press the up/down key the menu will be back (Last build haven't found this problem)

I'm not sure what you mean.
However I didn't change anything in the code related to [ALT] Menu.
This code is generic for all cameras.

Pavel

 

Related Topics