A450 1.00D porting

  • 21 Replies
  • 4502 Views
  • Publish
    Re: A450 1.00D porting
    « Reply #10 on: 10 / April / 2008, 04:03:30 »
    Advertisements
    Deleted
    « Last Edit: 22 / April / 2008, 17:05:31 by Barney Fife »
    [acseven/admin commented out: please refrain from more direct offensive language to any user. FW complaints to me] I felt it imperative to withdraw my TOTAL participation. Nobody has my permission, nor the right, to reinstate MY posts. Make-do with my quoted text in others' replies only. Bye

  • Publish
    Re: A450 1.00D porting
    « Reply #11 on: 10 / April / 2008, 04:46:25 »

    I'm not sure what you mean.
    However I didn't change anything in the code related to [ALT] Menu.
    This code is generic for all cameras.

    Pavel
    I will try to rec a video for the Menu.

    Here is The Video Hope you guys can watch it  :-X (This is animated Gif  :))

    and notice when the menu appears again. The title bar will be missing
    « Last Edit: 10 / April / 2008, 07:20:56 by mp9_sit »

  • Publish
    Re: A450 1.00D porting
    « Reply #12 on: 10 / April / 2008, 05:33:23 »

    re: Disappearing displays -- Are you aware of all the "half-press + directional button" shortcuts to turn on and off many features of CHDK? If not, learn them (mentioned in the FAQ and elsewhere).


    Nope i just automatic disappear at one but after press the direction button it will be back!
    « Last Edit: 10 / April / 2008, 06:11:29 by mp9_sit »

    *

    Offline brabl2

    • *
    • 31
    • A710IS
  • Publish
    Re: A450 1.00D porting
    « Reply #13 on: 10 / April / 2008, 09:40:57 »
    Here is The Video Hope you guys can watch it  :-X (This is animated Gif  :))
    and notice when the menu appears again. The title bar will be missing

    Hmm....this is VERY strange.
    There were some changes made in the trunk related to CHDK Menu between those two releases for A450 I posted here.
    You can try to delete your CHDK config files. It can help.
    At this moment I don't have any other meaningful advice for you.
    Is this blinking visibble only during browsing in Menu?
    What camera mode?  Play or Record or both?

    BTW, A450 was added into the trunk. Thanks to GrAnd.
    So now, you can enjoy new official releases, browse the code and solve that bug :)

    Pavel
    « Last Edit: 10 / April / 2008, 10:26:18 by brabl2 »


    *

    Offline mx3

    • ****
    • 372
  • Publish
    Re: A450 1.00D porting
    « Reply #14 on: 10 / April / 2008, 10:58:16 »
    when camera detects orientation change it redraws LCD.
    you can switch this feature off in canon menu and see if this is the reason
    skype: max_dtc. ICQ: 125985663, email: win.drivers(at)gmail, eVB decompiler

  • Publish
    Re: A450 1.00D porting
    « Reply #15 on: 10 / April / 2008, 11:05:22 »
    when camera detects orientation change it redraws LCD.
    you can switch this feature off in canon menu and see if this is the reason
    but the A450 should be no orientation sensors and i tried to turn the camera to different orientation it didn't have this problems.


    You can try to delete your CHDK config files. It can help.
    At this moment I don't have any other meaningful advice for you.
    Is this blinking visibble only during browsing in Menu?
    What camera mode?  Play or Record or both?

    i have try to delete the config files before but don't help
    and it will happen it all modes (include review mode)
    the most strange is....haven't found this problems in the last build :/

    BTW, A450 was added into the trunk. Thanks to GrAnd.

    I found there is a bug in the trunk release. the bug is like the attached picture.
    In M Mode if uesd the ND Filter (ND In) The F Numbers will be incorrect.
    But it is work in the Fireworks Mode
    « Last Edit: 10 / April / 2008, 11:48:58 by mp9_sit »

    *

    Offline brabl2

    • *
    • 31
    • A710IS
  • Publish
    Re: A450 1.00D porting
    « Reply #16 on: 10 / April / 2008, 15:44:44 »
    Attached are two builds based on previos trunk versions.
    Could you try them, if at least one of them is without that blinking bug.
    Thanks.

    Quote
    I found there is a bug in the trunk release. the bug is like the attached picture.
    In M Mode if uesd the ND Filter (ND In) The F Numbers will be incorrect.
    But it is work in the Fireworks Mode
    Hmmm...may be this is a feature :)
    PROPCASE_AV #23 is now used to display F-number. This value is not probably updated during ND-filter override.
    You can try to discover if the behaviour of any of following property cases reflects better ND filter override state.
    PROPCASE_USER_AV     26
    PROPCASE_MIN_AV       25

  • Publish
    Re: A450 1.00D porting
    « Reply #17 on: 10 / April / 2008, 20:05:33 »
    Quote
    I found there is a bug in the trunk release. the bug is like the attached picture.
    In M Mode if uesd the ND Filter (ND In) The F Numbers will be incorrect.
    But it is work in the Fireworks Mode
    Hmmm...may be this is a feature :)
    PROPCASE_AV #23 is now used to display F-number. This value is not probably updated during ND-filter override.
    You can try to discover if the behaviour of any of following property cases reflects better ND filter override state.
    PROPCASE_USER_AV     26
    PROPCASE_MIN_AV       25
    Yes the #23 #25 #26 won't change when using ND-Filter  override

    Attached are two builds based on previos trunk versions.
    Could you try them, if at least one of them is without that blinking bug.
    Thanks.
    I Will get a try Thx
    --------------------------------------------------------------------------------
    This two is OK at least i have try 10 mins there is no blinking bug
    « Last Edit: 10 / April / 2008, 20:24:51 by mp9_sit »


    *

    Offline brabl2

    • *
    • 31
    • A710IS
  • Publish
    Re: A450 1.00D porting
    « Reply #18 on: 11 / April / 2008, 02:26:48 »
    This two is OK at least i have try 10 mins there is no blinking bug
    Attached are another two newer builds, could you try them?

    Could you more describe that Menu disappearing.
    Could you say it happens for example once per 1 minute or once per 5 seconds.
    Or is it absolutely random.

  • Publish
    Re: A450 1.00D porting
    « Reply #19 on: 11 / April / 2008, 05:35:04 »
    This two is OK at least i have try 10 mins there is no blinking bug
    Attached are another two newer builds, could you try them?

    Could you more describe that Menu disappearing.
    Could you say it happens for example once per 1 minute or once per 5 seconds.
    Or is it absolutely random.
    Ok i will make a try when i back home :D

    Update : Seems to be no problems too in this two build!

    The Menu disappearing randomly. It seems don't have any formula for it. I will be make more try on it.:D
    « Last Edit: 11 / April / 2008, 08:24:27 by mp9_sit »

     

    Related Topics