Help to port > Canon IXUS SD40 / i7 Zoom / IXY DIGITAL L4 - General Discussion and Assistance - CHDK Forum  

Help to port > Canon IXUS SD40 / i7 Zoom / IXY DIGITAL L4

  • 8 Replies
  • 2075 Views
Help to port > Canon IXUS SD40 / i7 Zoom / IXY DIGITAL L4
« on: 03 / October / 2012, 13:02:29 »
Advertisements
Hi, there.
My name is Daniel, and I am totally new around here.
My wife has an japanese SD40 (named IXY DIGITAL L4), and I'd love to see it running the CHDK.

I am in the process of reading everything and learn how to port the CHDK to the SD40, and I'd like to know if there is some work done (I couldn't find anything but the firmware dump).

I'd like to know if there is a base port I should start with, and any tips about how to get started.
I am new to the C world too, but I hope I can learn a bit or two in the process and, of course, help the community while doing so.

Thank you very much!

Daniel

*

Offline srsa_4c

  • ******
  • 3814
Re: Help to port > Canon IXUS SD40 / i7 Zoom / IXY DIGITAL L4
« Reply #1 on: 03 / October / 2012, 17:44:33 »
Welcome!

For a start, try to find out your camera's firmware version, and dump the firmware (yes, there's already a dump, but it might be incomplete - I haven't checked though).
Some links:
http://chdk.wikia.com/wiki/Obtaining_a_firmware_dump
http://chdk.wikia.com/wiki/Canon_Basic/Scripts/Dumper
http://chdk.wikia.com/wiki/Canon_Basic
http://chdk.wikia.com/wiki/Canon_Basic/Card_Setup

I hope you have some programming experience, porting is hard if you don't understand what's going on.
You probably already know this wikia page: http://chdk.wikia.com/wiki/For_Developers, you can find useful links there.

If you succeeded dumping the camera's firmware, the next step is probably to set up a build environment (see the "Compiling the CHDK ..." links on the For developers page), and try to compile CHDK for a camera (choose a random one).

You can get more specific help if you tell us what operating system are you using on your PC.

Base port: find a camera from the same era (end of 2006 ... 2007, running VxWorks), and similar features. Sadly I can't tell which ports are the best, choose one with original comments (beware, many people doing the ports have simply copied comments from other ports, which may be misleading for a certain camera).

*

Offline ahull

  • *****
  • 634
Re: Help to port > Canon IXUS SD40 / i7 Zoom / IXY DIGITAL L4
« Reply #2 on: 24 / September / 2014, 08:54:15 »
Its been a while since anybody looked at this particular model, but I had one in my junk box, and finally got round to fixing it.

I have dumped a fresh copy of the Ixus i7 Zoom Firmware 1.00G since the previous links for it were dead and it wasn't in the google drive folders

If any of the devs with Google drive write access wants to add it to the google drive folders, they can grab it from here.

https://www.dropbox.com/s/c0c6u4j5jgli93s/PRIMARY.BIN?dl=0

I've also started the porting process with the assistance of nafraf,  (base port is based on Ixus700) so hopefully we will have something to share shortly.
« Last Edit: 24 / September / 2014, 08:56:34 by ahull »

*

Offline koshy

  • *****
  • 801
Re: Help to port > Canon IXUS SD40 / i7 Zoom / IXY DIGITAL L4
« Reply #3 on: 26 / September / 2014, 20:45:48 »
I've also started the porting process with the assistance of nafraf,  (base port is based on Ixus700) so hopefully we will have something to share shortly.
Interesting. This was the only DIGIC II/III VxWorks OS camera not supported by CHDK so I didn't get one. Seems like I'll need one in the foreseeable future... Good.


*

Offline ahull

  • *****
  • 634
Re: Help to port > Canon IXUS SD40 / i7 Zoom / IXY DIGITAL L4
« Reply #4 on: 03 / October / 2014, 12:49:53 »
A quick update, we have the very basic stuff sorted out, and I have fixed my build environment (was slightly screwy due to doing some cross compilation work for my raspberry Pi on the same laptop)..

We don't quite have anything building yet, but ...

If you need me to do anything at this point, let me know. I should be in the office tomorrow, and my be looking for a little distraction from my more routine problems.
There are some stubs address to be detected, to do that, ixusi7zoom disassembly code should be compared to a known port.  If you have time and access to the tools, please help with that.
Thanks.

.. so we have made a start. All I need now is some spare time  :blink:
« Last Edit: 03 / October / 2014, 12:52:16 by ahull »

*

Offline fe50

  • ******
  • 3096
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50

*

Offline ahull

  • *****
  • 634
Re: Help to port > Canon IXUS SD40 / i7 Zoom / IXY DIGITAL L4
« Reply #6 on: 10 / October / 2014, 11:16:51 »
Some progress... I have *something* building based on the 100g firmware above, but untested...
Keep watching this space.

EDIT: Starting camera in playback mode -> Menu -> Firmware Update ... works, camera restarts, no keys work, no chdk splash screen. We are starting to make serious progress.

OK I cheated slightly and uncommented this lot in stubs_entry_2.S to get it to build...

Code: [Select]
//TODO
NHSTUB(kbd_pwr_on,                  0xff82b05c)  //by comparsion to ixus65
NHSTUB(kbd_pwr_off,                 0xff82b078)  //by comparsion to ixus65
NHSTUB(kbd_read_keys,               0xff829d60)  //by comparsion to ixus65
NHSTUB(kbd_read_keys_r2,            0xff82aaac)  //by comparison to ixus65
NHSTUB(kbd_p1_f,                    0xff829c94)  //autodetection OK
NHSTUB(kbd_p1_f_cont,               0xff829ca0)  //autodetection OK
NHSTUB(kbd_p2_f,                    0xff82a078)  //autodetection OK

.. but what the heck.. its Friday after all.
« Last Edit: 10 / October / 2014, 11:53:30 by ahull »

*

Offline nafraf

  • *****
  • 1305
Re: Help to port > Canon IXUS SD40 / i7 Zoom / IXY DIGITAL L4
« Reply #7 on: 13 / October / 2014, 11:00:37 »
@ahull, please update your local copy, stubs_entry_2.S was updated, and loader files were added.


*

Offline ahull

  • *****
  • 634
Re: Help to port > Canon IXUS SD40 / i7 Zoom / IXY DIGITAL L4
« Reply #8 on: 14 / October / 2014, 07:36:18 »
Normal (non CHDK) boot... Press power button, power LED blinks 3 times, camera starts up.

That latest update builds, as before, starting in playback mode => Firmware Update works, camera restarts normally, power LED blinks 3 times, Canon screen appears, CHDK splash does not appear, arrow, Func/Set, print and Menu keys don't work, but otherwise camera OK, no watchdog reboot.

Mode selector works, but instantly takes a picture when changed to shoot mode (shoot button is not pressed).

Changing back to playback, then to shoot mode, takes another picture (shoot button is not pressed).

Power button does work, so better than before, previously I needed to remove the battery to recover camera.

In playback, no CHDK splash screen.
<ALT> button (print) doesn't work.

If I lock the SD card and boot, it claims "No memory card" in playback mode.
If I boot in Shoot mode, it instantly takes a picture, but also says "No memory card", then says "Cannot record"

Progress  :D
 
« Last Edit: 14 / October / 2014, 07:50:36 by ahull »

 

Related Topics