CHDK always boots up to "view image" mode and eTTL Flash in M mode - Hello, I'm a NEWBIE - HELP!! (Newbies assistance, User Guides and thank you notes) - CHDK Forum  

CHDK always boots up to "view image" mode and eTTL Flash in M mode

  • 11 Replies
  • 4110 Views
Advertisements
Hey guys,

Newbie here. I borrowed a G1x last night to try out the features of CHDK. After a little bit of work, I was able to get it installed and have it autoboot on startup. Two minor annoyances though that I hope someone can help with.

1. When I hit the power button, it always seems to boot to "picture viewer" mode. Then, I hit alt to deactivate the CHDK menu, then hit the shutter button to go to shooting mode.  Is there an option I missed where the camera will boot with CHDK but if I hit the power button and was previously in shooting mode, it'll stay in shooting mode?

2. I found a script that enables eTTL in manual mode. However, even with the script set to auto start, I have to hit the ALT button, hit the shutter button to run the script, then hit alt again to get back into normal shooting mode. Is there a way to have it run this script automatically on bootup without intervention from me? Better yet, does a current version of CHDK have this feature in one of it's menus that I missed that will make this easier?

The script is as follows:

@title Flash TTL
@param a Flash :0 TTL,1 Manul power (0,1)
@default a 0
@param c Flash compensation (-3~3)
@default c 0


rem DIGIC3 Flash Power id:121 0:auto 1:Manual
rem the default setting
get_prop 121 q
print "Default TTL: ", q
set_prop 121 a
get_prop 121 q
if q=0 then print "Flash in TTL mode"
if q=1 then print "Flash in Manual mode"


sleep 500


e=0
set_prop 127 e
get_prop 127 P
c=c*96
print "Old compensation:",P
P=P+c
set_prop 127 P
print "New compensation:",P

end




It works really well, but it's a feature that I'd rather have active rather than inactive. Can I modify the code so it does the following:

A. Camera boots to shooting mode if it was powered down in shooting mode
B. Upon startup, the script is run to activate eTTL without my intervention
C. Once script is run, set the camera to back to the normal non-alt menu

P.S. I'd even settle for if the camera did Step A and B but required me to hit the custom button to exit the ALT menu.

Any help you could provide would be appreciated. Great stuff guys!

Re: CHDK always boots up to "view image" mode and eTTL Flash in M mode
« Reply #1 on: 04 / October / 2012, 16:39:27 »
1. When I hit the power button, it always seems to boot to "picture viewer" mode. Then, I hit alt to deactivate the CHDK menu, then hit the shutter button to go to shooting mode.  Is there an option I missed where the camera will boot with CHDK but if I hit the power button and was previously in shooting mode, it'll stay in shooting mode?
Hold the power button down rather than click it.  Wait until the lens starts to extend.

Quote
2. I found a script that enables eTTL in manual mode. However, even with the script set to auto start, I have to hit the ALT button, hit the shutter button to run the script, then hit alt again to get back into normal shooting mode. Is there a way to have it run this script automatically on bootup without intervention from me? Better yet, does a current version of CHDK have this feature in one of it's menus that I missed that will make this easier?
Take a look in the Script menu.  The option to run the script on startup is there.

Ported :   A1200    SD940   G10    Powershot N    G16

Re: CHDK always boots up to "view image" mode and eTTL Flash in M mode
« Reply #2 on: 05 / October / 2012, 00:00:45 »
Thanks for the boot tip...works great!

The program auto boots and runs, but does not activate and eTTL doesn't work. I have to run the script manually to force it to work. I think maybe the script is running too quickly before the camera fully boots. In the code I posted above, can I add a sleep command to the top of the code to delay its running by a small amount?


Thanks!
Jim

Re: CHDK always boots up to "view image" mode and eTTL Flash in M mode
« Reply #3 on: 05 / October / 2012, 00:03:43 »
The program auto boots and runs, but does not activate and eTTL doesn't work. I have to run the script manually to force it to work. I think maybe the script is running too quickly before the camera fully boots. In the code I posted above, can I add a sleep command to the top of the code to delay its running by a small amount?
I was going to suggest putting a sleep(2000) right after the REM statements - but you essentially beat me to it.

Ported :   A1200    SD940   G10    Powershot N    G16


Re: CHDK always boots up to "view image" mode and eTTL Flash in M mode
« Reply #4 on: 05 / October / 2012, 00:37:09 »
One last thing...and this is a nit pick, but is there a way that after the script auto runs, the ALT menu is automatically hidden so I don't have to hit the custom button? It's not a big deal, but if this camera can boot, run the script to activate eTTL then hide the ALT menu, I have the Canon camera that's non-SLR that I've dreamed of!

Thanks

Re: CHDK always boots up to "view image" mode and eTTL Flash in M mode
« Reply #5 on: 05 / October / 2012, 00:41:28 »
One last thing...and this is a nit pick, but is there a way that after the script auto runs, the ALT menu is automatically hidden so I don't have to hit the custom button?
Add   
Code: [Select]
exit_alt at the bottom of the script right before the end statement.

You might find this wiki page helpful :  http://chdk.wikia.com/wiki/CHDK_Scripting_Cross_Reference_Page

Quote
It's not a big deal, but if this camera can boot, run the script to activate eTTL then hide the ALT menu, I have the Canon camera that's non-SLR that I've dreamed of!
You're going to have to start dreaming bigger  8)
« Last Edit: 05 / October / 2012, 00:44:25 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: CHDK always boots up to "view image" mode and eTTL Flash in M mode
« Reply #6 on: 05 / October / 2012, 00:58:57 »
THANK YOU THANK YOU THANK YOU!!!!

Ok maybe my dreams are small but you gotta understand my situation:

I'm a digital underwater photographer and I've been shooting with the A570 for years. Loved it, but it was basically on a slave strobe. It was a good starter camera and I got great shots. Now I want a full eTTL strobe so I have less overexposed shots. I've been watching G series cameras come out and when I saw the G1x, I saw that eTTL was enabled for all modes but manual...the one mode I shoot in. Then the G15 got announced and it's the same damn thing. Why not just shoot with SLR?  Because the underwater housing for the G series is about $600....SLR housings START at $1500 and are HUUUUGE. So you can see why this was crazy important. It's been a feature I've been sitting around waiting for in the G series and Canon never delivered.

I got the G1X to test the eTTL feature on just to make sure it really works. Is it a fairly good bet that assuming CHDK gets ported over to the new G15, that this script should still work there?  If not, is it typically easy to remedy?

Oh happy day!!!!

Re: CHDK always boots up to "view image" mode and eTTL Flash in M mode
« Reply #7 on: 05 / October / 2012, 01:09:27 »
I got the G1X to test the eTTL feature on just to make sure it really works. Is it a fairly good bet that assuming CHDK gets ported over to the new G15, that this script should still work there?  If not, is it typically easy to remedy?

Actually, I never stopped to ask you what camera you were using and you didn't really ask for comments on the script itself.  The original script you posted was designed for DIGIC III cameras - your G1X is a DIGIC IV.    Assuming you tested the script (? ? ?) then you must have gotten lucky that the set_prop and get_prop values used are the same between the two versions.

The G15 will likely work just as well as the G1X.  But as far as the G15 port goes,  you might want to read this :

link>CHDK FAQ : My camera isn't ported yet

Ported :   A1200    SD940   G10    Powershot N    G16


Re: CHDK always boots up to "view image" mode and eTTL Flash in M mode
« Reply #8 on: 05 / October / 2012, 01:42:40 »
I always love learning code, but I wanted to see if eTTL would work first. Plus I didn't want to bother people asking question after question about each line of code.

I guess I'll just cross my fingers that someone will port the G15. The G series is a pretty popular series, I'd think someone would eventually do it. I don't need it at this exact moment :)

Re: CHDK always boots up to "view image" mode and eTTL Flash in M mode
« Reply #9 on: 05 / October / 2012, 07:56:52 »
I guess I'll just cross my fingers that someone will port the G15. The G series is a pretty popular series, I'd think someone would eventually do it. I don't need it at this exact moment :)
Pretty good chance of that although the G10 was not ported until more than two years after it was released.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics