Starting port on A430, some progress has been made, help still needed - page 2 - General Discussion and Assistance - CHDK Forum supplierdeeply

Starting port on A430, some progress has been made, help still needed

  • 23 Replies
  • 10750 Views
Re: Starting port on A430, help needed
« Reply #10 on: 08 / July / 2008, 13:16:47 »
Advertisements
I have downloaded that file and extracted it,but their is no
 PS.FIR and Diskboot.bin files in them.

Only their is PRIMARY.bin file.

What to do ,please help.

*

Offline zfeet

  • **
  • 67
Re: Starting port on A430, help needed
« Reply #11 on: 08 / July / 2008, 14:51:10 »
I have downloaded that file and extracted it,but their is no
 PS.FIR and Diskboot.bin files in them.

Only their is PRIMARY.bin file.

What to do ,please help.

That firmware is not for upgrading your camera. It has been dumped from a regular A430 and it can be used for porting CHDK to A430.

Re: Starting port on A430, help needed
« Reply #12 on: 09 / July / 2008, 13:32:06 »
How to do that porting!!!!

Please explain..

*

Offline zfeet

  • **
  • 67
Re: Starting port on A430, help needed
« Reply #13 on: 09 / July / 2008, 16:29:14 »
As I really haven't ported any firmware yet, I really cannot help you. It is best if you read the CHDK wiki and the forums about porting CHDK.


Re: Starting port on A430, help needed
« Reply #14 on: 09 / July / 2008, 16:47:30 »
OK, I'm new here (first day). Gonna help with A430 (own one). I can speak C, a little ASM (no experiences) and understand computer function quite well, but have no experience with ARM and its asembler. Give me some days to get in topic. I have about 1 or 2 hours a day for this project  (yes I am bussy man  :(). If you need, may contact me via Jabber, my JID: Zd.Valek<at>jabber.cz

to smrtmazumdar:
Part of porting is already done  :), thanks to all!
You could find the information here (I just started studying that):
especially see the "Common articles" section.
You can find there this manual:


*

Offline zfeet

  • **
  • 67
Re: Starting port on A430, help needed
« Reply #15 on: 10 / July / 2008, 09:57:57 »
Great stuff, please keep us posted. I can help with testing your port.

Re: Starting port on A430, help needed
« Reply #16 on: 13 / July / 2008, 10:11:03 »
So I learned something about porting, but got a fatal problem. I have no access to IDA (the free version does not support ARM, the other is too expensive  >:(). I searched forums, searched the web and tried free tools. I managed to disassemble the primary.bin file, but probably incorrectly. The analysis is too hard without IDA (and there are only IDA tools here  :(). I'm sorry, but now I'm unable to make this done. I haven't finished yet, I'm just telling you not to await any progress from me shortly.

*

Offline zfeet

  • **
  • 67
Re: Starting port on A430, help needed
« Reply #17 on: 13 / July / 2008, 16:31:27 »
Here's some instructions on how to do it with free tools:

http://chdk.wikia.com/wiki/Gpl_Disassembling


Re: Starting port on A430, help needed
« Reply #18 on: 15 / July / 2008, 04:28:49 »
Thanks for the link. I tried that and got exactly the same results as before. There is still many "undefined instruction" lines. (I think none should be there.).
Now I'll continue searching the forum and wiki and try to validate the disassembly.

*

Offline zfeet

  • **
  • 67
Re: Starting port on A430, some progress has been made, help still needed
« Reply #19 on: 31 / July / 2008, 17:47:05 »
Thanks for the link. I tried that and got exactly the same results as before. There is still many "undefined instruction" lines. (I think none should be there.).
Now I'll continue searching the forum and wiki and try to validate the disassembly.

I've made some progress, check the first post.

 

Related Topics