SX40 HS MD SSS(motion detection speed,script,settings) - Script Writing - CHDK Forum supplierdeeply

SX40 HS MD SSS(motion detection speed,script,settings)

  • 5 Replies
  • 2042 Views
SX40 HS MD SSS(motion detection speed,script,settings)
« on: 06 / October / 2012, 16:08:11 »
Advertisements
Hi, First of all Thumbs up to CHDK for giving us the ADDED functionality and opportunity to use our camera to its full extent.

Secondly, what i am trying to do is to know what script, settings sx40 users are using to achieve good MD speeds, and what speed. cause i have been reading every page of every thread about MD but it dosent seems to give me enough speed to take a pic of a lightning bolt or a car at speed of 60kmph.
i have tried using ISO400, MF, Raw(with Dark Frame Subtraction Off), AWB off, bracketing off, single shot mode,etc. the only setting which got me close is decreasing my image quality to M2( or lower). which is taking all the fun out of it. i got 1.5-1 second on full quality image and 1-0.6 second on M2 quality.

Scripts i have used with settings:-
UBASIC/Scripts: Multipurpose Motion Detectionhttp://chdk.wikia.com/wiki/UBASIC/Scripts:_Multipurpose_Motion_Detection
Shot =0
Continuous shoot = 0,1
Threshold = 10,20,40
Compare Interval ms = 5,10
Compare Interval s = 0
Begin Delay = 1,2
Pix step = 1,5,10,20
Columns/Rows = 2/2,3/3,4/4
Dead frame = 0

and
http://chdk.wikia.com/wiki/UBASIC/Scripts:Lightning_script_--_Fudgey
with similar settings as above.
now i dont know much about modifying script but i can fix some odds and ends to get some output.

basically what i am trying to know is "is my camera capable of better results or not"?
if somebody got better results some how please share it. it will be very helpfull. thanks

Re: SX40 HS MD SSS(motion detection speed,script,settings)
« Reply #1 on: 06 / October / 2012, 16:09:41 »
and please share any images you have captured using MD.

Re: SX40 HS MD SSS(motion detection speed,script,settings)
« Reply #2 on: 06 / October / 2012, 16:29:49 »
The sx40hs code seems to have tried to implement detection of the right vid_get_viewport_live_fb for maximum speed but I can't comment on how well that implementation was done.

Did you read through this :
http://chdk.wikia.com/wiki/Motion_Detection

and try the speed tests here :
http://chdk.wikia.com/wiki/Motion_Detection#Speed_Testing
Ported :   A1200    SD940   G10    Powershot N    G16

Re: SX40 HS MD SSS(motion detection speed,script,settings)
« Reply #3 on: 08 / October / 2012, 11:09:39 »
thanks fo the reply..

yes, i have read that and these too..
http://chdk.setepontos.com/index.php?topic=405.150 (but i dont understand half of the stuff these people are talking about)

http://chdk.setepontos.com/index.php/topic,962.msg8632.html#msg8632

http://chdk.setepontos.com/index.php?topic=459.15

i just couldn't figure out why its not dropping bellow 1000ms or 1sec. i have tested its speed with "MD_Testv3 Barney Fife's MD Test v3".

i miss almost every important thing in that 1sec...
« Last Edit: 08 / October / 2012, 11:13:03 by bitts »


Re: SX40 HS MD SSS(motion detection speed,script,settings)
« Reply #4 on: 08 / October / 2012, 11:18:23 »
For a better response to your question then,  you might try posting a note in the SX40 porting thread (with a link to this thread rather than a repost).

Typically people who work on a camera port watch their own thread but might not be aware of new ones like this.   
Ported :   A1200    SD940   G10    Powershot N    G16

Re: SX40 HS MD SSS(motion detection speed,script,settings)
« Reply #5 on: 08 / October / 2012, 11:28:32 »
thanks

 

Related Topics