Sync Multi Cameras - 3d Modeling - page 3 - General Discussion and Assistance - CHDK Forum

Sync Multi Cameras - 3d Modeling

  • 63 Replies
  • 23613 Views
Re: Sync Multi Cameras - 3d Modeling
« Reply #20 on: 21 / October / 2012, 10:06:05 »
Advertisements
Thanks now I know I don't have to use the inverted remote script anymore.
You probably should not need any script at all if you only want sync'd shots using a USB remote. I think that the menu options cover what most people need/want to do.
http://chdk.wikia.com/wiki/USB_Remote#Multi-Camera_Synchronization
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Sync Multi Cameras - 3d Modeling
« Reply #21 on: 21 / October / 2012, 15:53:27 »
 
There is one thing I don't get:
"If the Enable Sync option is set in CHDK then each camera will wait for the final transition of the USB signal ( 5V to 0V )."
It seems just to be the opposite, with Sync enabled my camera takes a shot immediately when it gets 5V on the usb port and as reslult the camera's are not in sync. (elph300hs, one push, normal control mode)

Whith sync disabled it works as I would like it takes the shot as soon as the 5v is switched off, just like the inverted remote script.

Re: Sync Multi Cameras - 3d Modeling
« Reply #22 on: 21 / October / 2012, 16:18:40 »
There is one thing I don't get:
"If the Enable Sync option is set in CHDK then each camera will wait for the final transition of the USB signal ( 5V to 0V )."  It seems just to be the opposite, with Sync enabled my camera takes a shot immediately when it gets 5V on the usb port and as result the camera's are not in sync. (elph300hs, one push, normal control mode)
With sync disabled it works as I would like it takes the shot as soon as the 5v is switched off, just like the inverted remote script.
Strange.   Just tested it (for probably the 1000th time) on my SD940.  Works as expected - with or without sync enabled it takes the shot when 5V goes away.  I also enabled a 5 second sync delay to confirm it goes through the sync code.

So I checked the source for the ixus220_elph300hs and it appears the necessary hook for sync shooting is not enabled for that camera.    The hook to wait_until_remote_button_is_released is not implemented in capt_seq.c for any of the firmware versions.  The code hook to disable noise reduction is missing too.

This means you can still try to take pictures with sync disabled but the accuracy of the sync will be suspect.

This is probably fixable.  I won't have time to look at it for a few days (unless someone else volunteers) but I'll need somebody willing to test the fix.   Like you ?   (if so,  what firmware version do you have ?)

Update :  it seems somebody already noticed this : http://chdk.setepontos.com/index.php?topic=6341.msg87638#msg87638  ::)

« Last Edit: 21 / October / 2012, 16:24:49 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Sync Multi Cameras - 3d Modeling
« Reply #23 on: 21 / October / 2012, 16:55:55 »
It would be very nice if this can be fixed! And of course I am willing to test, I have camera's with firmware version 101E and 101G. And waiting a couple of days is no problem. Thanks for your help.


Re: Sync Multi Cameras - 3d Modeling
« Reply #24 on: 21 / October / 2012, 19:47:43 »
It would be very nice if this can be fixed! And of course I am willing to test, I have camera's with firmware version 101E and 101G. And waiting a couple of days is no problem. Thanks for your help.
If you PM me a "real" email address I'll send you a message directly when I'm ready for testing.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline srsa_4c

  • ******
  • 4426
Re: Sync Multi Cameras - 3d Modeling
« Reply #25 on: 22 / October / 2012, 00:50:45 »
The code hook to disable noise reduction is missing too.
I had a failed try on this (see this and the followup posts), I hope you'll have more success :)

Re: Sync Multi Cameras - 3d Modeling
« Reply #26 on: 25 / October / 2012, 03:08:07 »
waterwingz and microfunguy, good point about the accuracy of the measuring method.  I will probably get a cheap CRT system to test on.  However, I don't think I'll need sub-millisecond accuracy.  1-10 milliseconds should work.  But I still have to test the multi camera rig system with 123d Catch to make sure.

I'm changing my camera to the Elph 100HS because it has good image quality.  I just got 6 of them, so I should test Sync sometime soon. 

I hope I don't get the same problem as the Elph 300hs that Nestkast has.

After I run some test on the Elph 100hs, I'll share my findings.

Re: Sync Multi Cameras - 3d Modeling
« Reply #27 on: 25 / October / 2012, 08:20:57 »
I would also be interested in your findings. And perhaps I should also look for a cheap CRT monitor. I hope Waterwingz can fix the sync problem whith the Elph 300hs.


Re: Sync Multi Cameras - 3d Modeling
« Reply #28 on: 25 / October / 2012, 09:33:15 »
I hope I don't get the same problem as the Elph 300hs that Nestkast has.
The sync code in capt_seq.c for the Elph100 is there and appears to be correct so you should be fine.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Sync Multi Cameras - 3d Modeling
« Reply #29 on: 27 / October / 2012, 12:13:01 »
It would be very nice if this can be fixed! And of course I am willing to test, I have camera's with firmware version 101E and 101G. And waiting a couple of days is no problem. Thanks for your help.
links posted here :  http://chdk.setepontos.com/index.php?topic=6341.msg92525#msg92525
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics