Help - Script to change shutter speed not working - Script Writing - CHDK Forum supplierdeeply

Help - Script to change shutter speed not working

  • 7 Replies
  • 3947 Views
Help - Script to change shutter speed not working
« on: 28 / March / 2008, 18:25:08 »
Advertisements
I followed the scripting tutorial on the wiki and here is my code segment for the ixus70_sd1000 :( :'(

:set_shutter
get_tv t
print "Tv set to",t
wait_click
  is_key k "set"
    if k=1 then goto "k_set"
  is_key k "down"
    if k=1 then set_tv_rel 0-1
k=0
  is_key k "up"
    if k=1 then set_tv_rel 0+1
k=0
goto "set_shutter"


:k_set
.........


on the console
I see the t value vary up and down correctly but the shutter speed doesnt seem to change

please help

Re: Help - Script to change shutter speed not working
« Reply #1 on: 28 / March / 2008, 20:09:33 »
Deleted
« Last Edit: 22 / April / 2008, 15:27:13 by Barney Fife »
[acseven/admin commented out: please refrain from more direct offensive language to any user. FW complaints to me] I felt it imperative to withdraw my TOTAL participation. Nobody has my permission, nor the right, to reinstate MY posts. Make-do with my quoted text in others' replies only. Bye

Re: Help - Script to change shutter speed not working
« Reply #2 on: 06 / April / 2008, 21:35:59 »
Is this to say that none of the scripts will work in Allbest's builds?
I ask because I just loaded one on my TX-1, which is working for the most part, but I can't seem to run scripts on it. You've stated this problem with his builds in other posts.
You smite like a girl!

Re: Help - Script to change shutter speed not working
« Reply #3 on: 07 / April / 2008, 03:09:26 »
Deleted
« Last Edit: 22 / April / 2008, 15:27:36 by Barney Fife »
[acseven/admin commented out: please refrain from more direct offensive language to any user. FW complaints to me] I felt it imperative to withdraw my TOTAL participation. Nobody has my permission, nor the right, to reinstate MY posts. Make-do with my quoted text in others' replies only. Bye


Re: Help - Script to change shutter speed not working
« Reply #4 on: 07 / April / 2008, 07:44:42 »
Honestly, you're being less than helpful to me, and acting like you have a personal grievance against Mr. "Allbest".
As per the "wiki", I have nothing but respect for the very celebrated "Allbest", and of course, as per this forum, you are obviously held in highest esteem and to be respected.
I am merely a "no one", standing in your gigantic shadows, ne'er getting warmth from the sun, yet still sustained by being in the proximity of such greatness.
Now that I've spread the "ooze of respect" evenly around here, please don't use my failure as another grindstone for your ax.

In your opinion, which is the best build? Or perhaps there a thread or post where the reality checks are all listed between the builds instead of the page in the wiki that strokes everyone evenly for their contributions?
If one is so much better than another, -and clearly you do think so, then please, by all mean elaborate further than "Allbest's builds are useless".

Thanks.
You smite like a girl!

Re: Help - Script to change shutter speed not working
« Reply #5 on: 07 / April / 2008, 08:32:20 »
Deleted
« Last Edit: 22 / April / 2008, 15:27:56 by Barney Fife »
[acseven/admin commented out: please refrain from more direct offensive language to any user. FW complaints to me] I felt it imperative to withdraw my TOTAL participation. Nobody has my permission, nor the right, to reinstate MY posts. Make-do with my quoted text in others' replies only. Bye

Re: Help - Script to change shutter speed not working
« Reply #6 on: 07 / April / 2008, 09:45:49 »
I've read a few times in past posts by you that you feel unappreciated, and that you refuse to continue doing all the "dog work".
I completely understand.
Thanks ever so much for all of your hard efforts.
Thanks for the "smite", and especially thanks for this:
Quote
May you enjoy 3 more frustrating months of also getting no help on these issues.
Very nice, indeed, Mr. Fife.

I was simply asking some rudimentary questions, the likes of which often get shoved aside as too "noobish" to bother with. I'll go as far as to suggest that you're "bothering" answering because in continuing a dialog with you, I offer you yet another opportunity to cry about how unappreciated you are and how purely lazy everyone else is.
Quote
(Then no doubt, after you get your answer, you'll be just like all the rest that don't bother to record that information where it belongs, in the Wikia pages in the uBASIC sections, expecting everyone else to hunt down that important information again from scattered and unrelated posts in these forums.)
I'd be glad to contact Mr. Allbest for the information and edit the wiki if you'll just teach me Russian, uBASIC, and just wtf this whole thing is all about, along with a crash course in general programming.

I have been working to what very, very limited ability I have with another member to unravel the keyboard of the TX-1. So I made a chart mapping the buttons and kept editing it with updates; Big Deal. But mind you, I really have NO IDEA how all this works, and I think that by not taking any of that into account, you are demonstrating bitterness and hostility by being downright vindictive towards me.
Your misplaced angst shall not rest upon MY shoulders, Mr. Fife. "Smite" my "Karma" all you like, it doesn't justify your behavior.
You smite like a girl!

Re: Help - Script to change shutter speed not working
« Reply #7 on: 07 / April / 2008, 09:48:57 »
Ask Allbest, he claims that his builds are 100% compatible with all old scripts and all original uBASIC commands. (excuse me while I chuckle)
-Furthermore, make no mistake about it, your snide cynicism is what motivated my original retort. It shows perhaps more than you think.
You smite like a girl!


 

Related Topics