A1300 Porting - page 2 - DryOS Development - CHDK Forum  

A1300 Porting

  • 31 Replies
  • 7694 Views
Re: A1300 Porting
« Reply #10 on: 12 / November / 2012, 20:11:02 »
Advertisements
I have noticed that 1 function does work on the 1/2 press of the shutter release. Up will turn the Manual Focus On & Off.
This sounds like the key sequence used by Canon to enable auto focus lock (AFL) - nothing to do with CHDK.  Does it doe this when you boot the camera normally  (i.e. not CHDK) ?

Ported :   A1200    SD940   G10    Powershot N    G16

Re: A1300 Porting
« Reply #11 on: 13 / November / 2012, 12:58:35 »
Hello everyone
The Powershot A1300 has full time auto focus. This switch on & off function is definitely in the CHDK 1/2 press of the Shutter menu. An up press of the Joystick pad turns on & off Manual focus. The other 1/2 press menus do not respond to their key presses. I think the porting process is the computer code that makes them work has to be completed yet. No 1/2 Press functions worked when I was running the A810 CHDK in my A1300. Have fun porting.
73
Gerry

*

Offline nafraf

  • *****
  • 1306
Re: A1300 Porting
« Reply #12 on: 14 / November / 2012, 06:16:22 »
The Powershot A1300 has full time auto focus. This switch on & off function is definitely in the CHDK 1/2 press of the Shutter menu. An up press of the Joystick pad turns on & off Manual focus. The other 1/2 press menus do not respond to their key presses. I think the porting process is the computer code that makes them work has to be completed yet. No 1/2 Press functions worked when I was running the A810 CHDK in my A1300. Have fun porting.
Which capture mode are you using for testing the 1/2 Press functions?

In a810, and my guess is that in a1300 too, the AFL is activated (even without CHDK)  in this way:
- Put the camera in P or LIVE mode
- Press the "left/flower" button after "half pressing & holding" the shutter release button.

Re: A1300 Porting
« Reply #13 on: 14 / November / 2012, 23:27:52 »
Hello All Porting
I just loaded the new Alpha version of the CHDK and now the 1/2 press functions work for the 4 positions of the joystick Function Button I just tried those functions they seem to be good features.
73
Gerry


*

Offline nafraf

  • *****
  • 1306
Re: A1300 Porting
« Reply #14 on: 15 / November / 2012, 05:58:00 »
I just loaded the new Alpha version of the CHDK and now the 1/2 press functions work for the 4 positions of the joystick Function Button I just tried those functions they seem to be good features.
OK, thanks. 
Could you run the test scripts as described here: http://chdk.wikia.com/wiki/Testing ?
The scripts are in the diretory /CHDK/SCRIPTS/TEST/ in your camera.

Re: A1300 Porting
« Reply #15 on: 15 / November / 2012, 13:22:24 »
Hello All Porting
I ran the tests with good results on the setmode and ubtests both passed the second time I ran them the llibtst.lua test failed. If required I will later send the log file.
73
Gerry

*

Offline nafraf

  • *****
  • 1306
Re: A1300 Porting
« Reply #16 on: 15 / November / 2012, 15:04:29 »
I ran the tests with good results on the setmode and ubtests both passed the second time I ran them the llibtst.lua test failed. If required I will later send the log file.
Could you post the log?  I expect an error due to mkdir function. ;)
Thanks

Re: A1300 Porting
« Reply #17 on: 16 / November / 2012, 11:18:57 »
I Emailed you the log yesterday afternoon. You should have received it by now.
73
Gerry



Re: A1300 Porting
« Reply #18 on: 26 / November / 2012, 17:17:17 »
Hi everyone,

I just bought an A1300 seeing that there was a stable port, only to discover my firmware version is 1.00e and doesn't work with the 1.00d version of CHDK.  I've successfully gotten a dump of the firmware and hoping someone can help get a version up and running for my firmware too.  I'm happy to help with testing, etc too, just need guidance.

Firmware A1300 1.00e:
https://dl.dropbox.com/u/3800992/A1300/PRIMARY.BIN

Thanks!

*

Offline nafraf

  • *****
  • 1306
Re: A1300 Porting
« Reply #19 on: 26 / November / 2012, 19:08:34 »
I just bought an A1300 seeing that there was a stable port, only to discover my firmware version is 1.00e and doesn't work with the 1.00d version of CHDK.  I've successfully gotten a dump of the firmware and hoping someone can help get a version up and running for my firmware too.  I'm happy to help with testing, etc too, just need guidance.

Hi, I sent a private message with the link to chdk for a1300 100e. Please test it and post the results.

 

Related Topics