SX50 HS porting thread - page 18 - DryOS Development - CHDK Forum supplierdeeply

SX50 HS porting thread

  • 350 Replies
  • 146444 Views
Re: SX50 HS porting thread
« Reply #170 on: 19 / March / 2013, 16:13:47 »
Advertisements
Recently got an SX50, but am quite the novice photographer so am just getting into some of the features that CHDK has to offer. Reading through this thread and searching around online I was able to gather enough info to get a 2GB card (seemed my 16GB wouldn't work) format it and load the vers.req file onto it. Then I loaded the 100c CHDK build from earlier in this thread via CardTricks and made the SD bootable. Now it autoboots into CHDK fine via locking the SDCARD. All seems to be working great.

But as I said, I am a novice user, and probably am not delving deep enough to run into many problems, although I am tinkering quite a bit and all seems to work as it should.

However, how do I over ride the ISO limit, max shutter speed, and max shutter length?

Re: SX50 HS porting thread
« Reply #171 on: 19 / March / 2013, 16:28:08 »
Recently got an SX50, but am quite the novice photographer so am just getting into some of the features that CHDK has to offer. Reading through this thread and searching around online I was able to gather enough info to get a 2GB card (seemed my 16GB wouldn't work) format it and load the vers.req file onto it.
Then I loaded the 100c CHDK build from earlier in this thread via CardTricks and made the SD bootable. Now it autoboots into CHDK fine via locking the SDCARD. All seems to be working great.
I'm afraid you did this the hard way - including the use of Cardtricks.    You can certainly use a 16G or larger card but not with Cardtricks.     Read through this to setup your 16G card :  http://chdk.wikia.com/wiki/Prepare_your_SD_card.   The STICK utility linked there is a good way to go.

Quote
However, how do I over ride the ISO limit, max shutter speed, and max shutter length?
Once you have the CHDK menu open, go to the first menu item and there is a whole list of override options there.  They become effective when you exit CHDK <ALT>mode and go back to regular camera shooting mode.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline nafraf

  • *****
  • 1308
Re: SX50 HS porting thread
« Reply #172 on: 19 / March / 2013, 16:30:08 »
However, how do I over ride the ISO limit, max shutter speed, and max shutter length?
http://chdk.wikia.com/wiki/CHDK_User_Manual   ;)

Ported :   A1200    SD940   G10    Powershot N    G16


Re: SX50 HS porting thread
« Reply #174 on: 19 / March / 2013, 17:13:07 »
Thank you.

Waterwingz, nafraf, pointing me in the right direction for the 16gb card install is greatly appreciated. I searched for quite awhile, and found a wiki, but it was nowhere near as helpful or detailed as that one, and most seemed to only talk about installing it for some reason. It still seems to be pretty obscure on search lists.

Now for the real question, what features still need to be tested? Anyway I can help? Just point me in the right direction (what is still questionable, what logs to post). I have been active in modding communities for nearly every device I've ever owned... I'm just a guy who loves to tinker in the advanced settings and really "dial" in my devices for no good reason, while hopefully helping some devs who let me do this cool stuff!

Re: SX50 HS porting thread
« Reply #175 on: 20 / March / 2013, 19:55:35 »
Got the camera today - f/w 1.00C.   Its a really nice toy!

- I'm not sure if power-up button patch is correct
Power-up button works correctly - short press gets into play mode.  Longer press starts shooting mode.

A couple of things I noticed right away (helps to have 3 other CHDK cams to compare to).

1) The <ALT> button on power up is the Playback button.  As this camera has a shortcut/print button,  it really should default to that button.
2) If you redefine the <ALT> button you get a choice of shortcut, flash or video. But you can't get back to the Playback button.
3) Menu colors are grey on grey on light grey. CAM_LOAD_CUSTOM_COLORS is enabled but something is not right there.

So when I get a minute I'll fix those three and submit a patch. Time for some more detailed testing (when I pry the cameras out of its owners fingers again that is).
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline lapser

  • *****
  • 1093
Re: SX50 HS porting thread
« Reply #176 on: 21 / March / 2013, 00:46:39 »
f/w 1.00C
Power-up button works correctly
Works on 1.00B too
Quote
1) The <ALT> button on power up is the Playback button.
It's the shortcut button for me on 1.00B. I didn't modify it.
Quote
3) Menu colors are grey on grey on light grey. CAM_LOAD_CUSTOM_COLORS is enabled but something is not right there.
I noticed the colors were like that too.
Quote
So when I get a minute I'll fix those three and submit a patch. Time for some more detailed testing (when I pry the cameras out of its owners fingers again that is).
Thanks! I really appreciate everyone working on this camera. The 50X optical zoom is fantastic. I just got a better ball head for my tripod to reduce the shaking in the wind at high magnification.
EOS-M3_120f / SX50_100b / SX260_101a / G1X_100g / D20_100b
https://www.youtube.com/user/DrLapser/videos

Re: SX50 HS porting thread
« Reply #177 on: 21 / March / 2013, 09:00:58 »
Thanks! I really appreciate everyone working on this camera. The 50X optical zoom is fantastic.
Just started playing with it.  Built-in HDR that produces a final image plus high speed multi-shot modes take over some of the things I used to need CHDK for.
Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline lapser

  • *****
  • 1093
Re: SX50 HS porting thread
« Reply #178 on: 21 / March / 2013, 10:37:23 »
Just started playing with it.  Built-in HDR that produces a final image plus high speed multi-shot modes take over some of the things I used to need CHDK for.
I really like the built in RAW too. I haven't used the high speed muti-shot, other than testing. But how could CHDK do that?
EOS-M3_120f / SX50_100b / SX260_101a / G1X_100g / D20_100b
https://www.youtube.com/user/DrLapser/videos

Re: SX50 HS porting thread
« Reply #179 on: 21 / March / 2013, 20:01:55 »
The moon in early evening - unretouched jpg from my sx50 exactly as it came out of the camera.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics