SX50 HS porting thread - page 21 - DryOS Development - CHDK Forum supplierdeeply

SX50 HS porting thread

  • 350 Replies
  • 151052 Views
*

Offline yukia10

  • *
  • 32
  • SX50_100c
Re: SX50 HS porting thread
« Reply #200 on: 27 / March / 2013, 09:34:41 »
Advertisements
Is the baseline change of a histogram specific to 1.00c or is it usual on CHDK?

Re: SX50 HS porting thread
« Reply #201 on: 27 / March / 2013, 09:51:48 »
Is the baseline change of a histogram specific to 1.00c or is it usual on CHDK?
I have not seen it do that on my other cameras - what settings were you using in the histogram menu?
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline yukia10

  • *
  • 32
  • SX50_100c
Re: SX50 HS porting thread
« Reply #202 on: 27 / March / 2013, 10:02:28 »
Is the baseline change of a histogram specific to 1.00c or is it usual on CHDK?
I have not seen it do that on my other cameras - what settings were you using in the histogram menu?

Here is a screen shot.

Re: SX50 HS porting thread
« Reply #203 on: 27 / March / 2013, 12:16:35 »
Here is a screen shot.
Same settings I'm using on my cameras (don't have the SX50 right now) and they don't bounce like that.  If nobody else comes up with anything, I'll add it to the "to be tested" list.
Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline lapser

  • *****
  • 1093
Re: SX50 HS porting thread
« Reply #204 on: 27 / March / 2013, 12:37:39 »
Or course the comment about "Firmware Update booting only" was a mistake
If there are no more complaints this week I'm going to recommend releasing this with Beta status.
Since you posted a "full" version, I assumed you had compiled the firmware update part. Now that I look at it, I get a November, 2012 build date with firmware update. I guess the question is, why are the colors correct with the old version? I assume it was because I did the autoboot first after deleting the config file, so it saved the correct colors that were then used by the firmware update version.

I think the modemap issue was resolved. The 2 bogus modemap entries that I found were not reachable with the camera without CHDK, and they don't work correctly if you set them with CHDK, so they shouldn't be in CHDK's modemap table. The comments were added at reyalp's sugggestion to explain this.

I haven't used video much with CHDK. Is quality override possible on other newer cameras? For HD video, the 4GB file size limit seems to be reached before the time limit, so I haven't worried about overriding that. Would you like me to test the time limit override with SD video?

[EDIT] I made an 84 minute movie in SD, so the time override works.
"The maximum movie length is a second shy of 30 minutes per clip in HD or one hour per clip in the other formats, or when the file size reaches 4GB."

The camera has its own live histogram you activate under custom display. The CHDK histogram feature works a lot of the time, but it flashes an incorrect histogram about twice per second sometimes. That appears to be a bug. When it works, the baseline is correct.

stubs cleaning is above my pay grade at the moment. I know Phil fixed the problem with the log10() function address.
« Last Edit: 27 / March / 2013, 14:08:56 by lapser »
EOS-M3_120f / SX50_100b / SX260_101a / G1X_100g / D20_100b
https://www.youtube.com/user/DrLapser/videos

*

Offline yukia10

  • *
  • 32
  • SX50_100c
Re: SX50 HS porting thread
« Reply #205 on: 27 / March / 2013, 17:39:51 »
The camera has its own live histogram you activate under custom display. The CHDK histogram feature works a lot of the time, but it flashes an incorrect histogram about twice per second sometimes. That appears to be a bug. When it works, the baseline is correct.
A histogram bounces sometimes but not always. It is not so important for me. I thought if it is specific to 1.00c, there is a bug in the firmware porting from 1.00b to 1.00c.

Re: SX50 HS porting thread
« Reply #206 on: 28 / March / 2013, 21:40:59 »
Hi, Sorry but someone can put here the link to download the last version of CHDK to SX50 HS for install in my SD card, cause today I buy this camera and I will like test the CHDK in SX50

thanks.

Re: SX50 HS porting thread
« Reply #207 on: 28 / March / 2013, 21:51:38 »
Hi, Sorry but someone can put here the link to download the last version of CHDK to SX50 HS for install in my SD card, cause today I buy this camera and I will like test the CHDK in SX50
Go back to post 191 in this thread.

You are probably going to want to read through this too :  http://chdk.wikia.com/wiki/Prepare_your_SD_card
Ported :   A1200    SD940   G10    Powershot N    G16


Re: SX50 HS porting thread
« Reply #208 on: 28 / March / 2013, 21:58:49 »

Go back to post 191 in this thread.

You are probably going to want to read through this too :  http://chdk.wikia.com/wiki/Prepare_your_SD_card

Thanks... can you tell me how I know what version I need download? C or D?

thanks

Re: SX50 HS porting thread
« Reply #209 on: 28 / March / 2013, 22:00:32 »
Thanks... can you tell me how I know what version I need download? C or D?
You really need to read through the link I posted.  The answer to your question and to several others that you will have next are all explained there.


Hint :  http://chdk.wikia.com/wiki/ACID
Another hint : http://chdk.wikia.com/wiki/Prepare_your_SD_card#For_Cameras_Released_After_2010_:
« Last Edit: 28 / March / 2013, 22:10:20 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal