IXUS75/SD750 1.01a | 1.00b | 1.02a - Update 09Nov2008 - Passing the Torch - page 2 - General Discussion and Assistance - CHDK Forum supplierdeeply

IXUS75/SD750 1.01a | 1.00b | 1.02a - Update 09Nov2008 - Passing the Torch

  • 381 Replies
  • 117791 Views
*

Offline TPC

  • *
  • 46
  • SD750 1.01a
Re: IXUS75/SD750 - Help with IDA
« Reply #10 on: 03 / April / 2008, 00:25:41 »
Advertisements
Alright, got the keyboard working. The camera seems to take JPEG pictures fine but barfs a bunch of random trash data into a CRW file when I try RAW mode. Movie recording mode crashes the camera. The "circle" menu likes to get in the way and mess up the CHDK menu.

But, it works, and if you'd like to play with the progress, here you go:

EDIT: Link removed, out of date, keep scrolling...

Now, it's 11:25PM here in Texas. I'm off to bed. I will continue working on it tomorrow...
« Last Edit: 06 / April / 2008, 00:43:31 by TPC »

Re: IXUS75/SD750 - Help with IDA
« Reply #11 on: 03 / April / 2008, 07:02:44 »
I'll try to work on it today if possible. Good work, TPC

edit: Looks like your firmware doesn't work on 1.02a at all. Firmware upgrades fine but camera doesn't start or come on at all. I'm not a programmer, so not sure what the next steps are. I'll keep reading up on it.

Same results with my 2Gig card and my 512 meg card.
« Last Edit: 03 / April / 2008, 07:28:40 by somacore »

*

Offline TPC

  • *
  • 46
  • SD750 1.01a
Re: IXUS75/SD750 - Help with IDA
« Reply #12 on: 05 / April / 2008, 02:16:19 »
Update: still working on it, minor fixes.

I have two problems I'm running into now:

-First, when I try to override the shutter speed and take a picture, the camera chirps and flashes the AF LED like normal, then shuts down. I've been all over the trunk scripts and I can't figure out the sequence of function calls associated with this action so that I can find the address that needs to be changed. Can someone provide a hint?

-Second, in video recording mode: before modifying movie_rec.c, the camera would pause for about a half second and then shut down after full-pressing record in video mode. After modification it locks up and then shuts down after a few seconds. Nothing is written to the SD card.

Here's my platform source, if anyone would care to have a look:

EDIT: Link removed, out of date

IDA database:

EDIT: Link removed, out of date
« Last Edit: 06 / April / 2008, 00:44:00 by TPC »

*

Offline TPC

  • *
  • 46
  • SD750 1.01a
Re: IXUS75/SD750 - Help with IDA
« Reply #13 on: 06 / April / 2008, 00:47:29 »
No hints? Hmm, that's okay, I figured it out myself.

Here's the latest firmware:

zSHARE - chdk_sd750101a_05apr08_2341.zip

Right now the only problem that I can find is that the zebra feature works just fine most of the time, then randomly explodes with garbled over/under exposure colors. Occasionally the entire screen blinks underexposed, and then the keyboard locks up.

But, like I said, that's the only problem. Zebra seems to work okay about 80% of the time. Must be the planets aligning.

So, there you go, everything else works - AV override, video, RAW, SD card space, battery meter, all that fun CHDK stuff. Hopefully someone can test it out for a few days. Meanwhile I'll put together the wiki page and see about getting the code into the trunk.

Woo.


*

Offline GrAnd

  • ****
  • 916
  • [A610, S3IS]
    • CHDK
Re: IXUS75/SD750 - Help with IDA
« Reply #14 on: 06 / April / 2008, 08:21:21 »
FYI... Just discovered... SD1000 (IXUS70) has two firmware versions 1.01a and 1.01b, which seem to be compatible as have a minor differences. It seems we have the same situation here: 1.01a and 1.01b are almost the identical.
CHDK Developer.

Re: IXUS75/SD750 1.01a - Port (Maybe) Finished
« Reply #15 on: 06 / April / 2008, 16:09:37 »
Alrighty, I've made progress on the SD750 1.02a firmware. I modified boot.c from my dump and the camera now upgrades the firmware and restarts, but no CHDK splash appears and it doesn't appear as though CHDK is loaded in any way.

Here's the bin and fir files, I'll keep working on this.

sd750_1.02a.rar - 0.21MB


Re: IXUS75/SD750 1.01a - Port (Maybe) Finished
« Reply #16 on: 07 / April / 2008, 07:43:17 »
Hey thanks for working on this model.

Here's my feedback:
On an eurpean  Ixus75, I uploaded the files to my SD card, went to the "firm update" option (1.0.1.0 -> 1.0.1.1), and then the cam wen off, no way to restart it, bricked until i removed the battery and flushed the firmware.

Obviously i'm a total newb. Did I do something wrong (i renamed the FIR file to PS.FIR)?

*

Offline GrAnd

  • ****
  • 916
  • [A610, S3IS]
    • CHDK
Re: IXUS75/SD750 1.01a - Port (Maybe) Finished
« Reply #17 on: 07 / April / 2008, 08:37:25 »
@loteq
Did you check your camera firmware version?
CHDK Developer.


Re: IXUS75/SD750 1.01a - Port (Maybe) Finished
« Reply #18 on: 07 / April / 2008, 13:29:51 »
@GrAnd: No i just checked. My firmware version number is GM1.01B

Can I do something to help? I am not a coder so i am way out of my depth in programming issues.
« Last Edit: 07 / April / 2008, 13:52:04 by loteq »

Re: IXUS75/SD750 1.01a - Port (Maybe) Finished
« Reply #19 on: 07 / April / 2008, 18:10:00 »
@GrAnd: No i just checked. My firmware version number is GM1.01B

Can I do something to help? I am not a coder so i am way out of my depth in programming issues.

You can dump your firmware.

There's instructions on here how to use udumper. Find those and we can disassemble it and port CHDK to your firmware.

 

Related Topics