IXUS 240/ELPH 320 HS Porting thread - page 24 - DryOS Development - CHDK Forum
supplierdeeply

IXUS 240/ELPH 320 HS Porting thread

  • 286 Replies
  • 68786 Views
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #230 on: 19 / April / 2015, 09:13:35 »
Advertisements
If only I was a prgogrammer, I would surely try to help in practise.  :(
Anyway, I'll check for updates., hoping that  in the meanwhilemy post could be useful to developers.Thanks a lot!

Lorenzo

*

Online reyalp

  • ******
  • 12649
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #231 on: 21 / April / 2015, 23:33:06 »
If only I was a prgogrammer, I would surely try to help in practise.  :(
Anyway, I'll check for updates., hoping that  in the meanwhilemy post could be useful to developers.Thanks a lot!
What firmware canon firmware version does your ixus240 have, 101a or 102a?

Regarding the button not being visible in record mode under 1.3, have you tried touching the spot where it should be? It's possible that button just isn't drawn.

With 1.4 does the camera shut down, or just freeze with the screen still on?
Don't forget what the H stands for.

Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #232 on: 21 / April / 2015, 23:45:26 »
Regarding the button not being visible in record mode under 1.3, have you tried touching the spot where it should be? It's possible that button just isn't drawn.
I asked the OP about that  - the answer was that touching the spot did nothing other than bring up a Canon notice about touch autofocus.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #233 on: 22 / April / 2015, 05:59:33 »
Firmware 101a, identified by Stick and downloaded accordingly.
With 1.4 camera freezes but don't shut down.
About the button in record mode, waterwingz already told you.

Lorenzo


*

Online reyalp

  • ******
  • 12649
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #234 on: 23 / April / 2015, 00:44:51 »
Firmware 101a, identified by Stick and downloaded accordingly.
With 1.4 camera freezes but don't shut down.
About the button in record mode, waterwingz already told you.
Thanks for the info. Here's a 1.4 build of revision 4144, from before I made the keyboard changes. Can you please check if it still hangs, and whether the alt button appears.
Don't forget what the H stands for.

Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #235 on: 23 / April / 2015, 05:52:32 »
Hello and thank you! :) I installed the 1.4 you provided (via Licks utility). CHDK starts, doesn't hang, takes pictures... Well, from the file browser I can see a .dng file in image folder even if I didn't make the badpixel thing, don't know if I can open it (try later, must go back to work). Anyway, I still can't see alt button in capture mode...

Lorenzo

*

Online reyalp

  • ******
  • 12649
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #236 on: 23 / April / 2015, 16:01:09 »
Hello and thank you! :) I installed the 1.4 you provided (via Licks utility). CHDK starts, doesn't hang, takes pictures...
Thanks, that confirms the hang is probably something I broke in the keyboard changes. I'll take another look at this when I have some time.

Quote
Well, from the file browser I can see a .dng file in image folder even if I didn't make the badpixel thing
The badpixel.bin is only require if you are shooting DNG 1.1. DNG 1.3 doesn't require it, but you may see the bad pixels depending which software you use to process the DNG. Most non-adobe software doesn't support the 1.3 bad pixel removal method. In raw therapee the "dead pixel filter" setting may do an OK job.

Quote
I still can't see alt button in capture mode...
This is a fairly serious bug too...
Don't forget what the H stands for.

Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #237 on: 23 / April / 2015, 16:44:45 »
So, are you, reyalp, the maintainer of the Ixus 240 firmware? Glad to meet you here, and congrats for the beautiful job of the CHDK team! Thanks for clarifying the badpixel.bin use. I can open the DNG produced by the camera with Adobe Camera Raw without a problem, and also with Raw Photo Processor; not tried with Raw Therapee yet. Sensor is quite noisy anyway. I take the opportunity to tell you that firmware hangs (or, to say better, camera shuts down after taking a picture) if I try to use the ISO override (i.e. with ISO 4000 or 5000).

Lorenzo


*

Online reyalp

  • ******
  • 12649
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #238 on: 26 / April / 2015, 19:48:44 »
So, are you, reyalp, the maintainer of the Ixus 240 firmware?
I am one of the CHDK developers, we don't really have maintainers for individual ports except when one of the developers owns the camera.  I don't have an ixus240 or any touch camera. Nafraf did most of the original ixus240 work, also "blind" without the camera.

I spent some time looking at the keyboard changes and unfortunately haven't found any significant way it differs from the old code. I may be missing something, or maybe the bug is always there and the symptoms just depend on how things end up in memory.

I did find one apparent bug in the button drawing code. I don't really think it would cause the problems you've seen, but I've attached a test build.

Looking back in the thread, it seems like there were some similar issues in development, discussed around http://chdk.setepontos.com/index.php?topic=9005.msg102223#msg102223

There is also some discussion of when the CHDK button is supposed to show up:
http://chdk.setepontos.com/index.php?topic=9005.msg102256#msg102256
If I understand the code correctly, it's supposed to show up in rec mode, but not in half press. I'm not clear from the posts exactly what the intended behavior was.

Quote
I take the opportunity to tell you that firmware hangs (or, to say better, camera shuts down after taking a picture) if I try to use the ISO override (i.e. with ISO 4000 or 5000).
FWIW, CHDK ISO overrides generally don't work beyond the factory canon limits. If you can get a romlog as described in http://chdk.wikia.com/wiki/Debugging#Camera_crash_logs_.28romlog.29 that may shed light on the crash.
Don't forget what the H stands for.

*

Online reyalp

  • ******
  • 12649
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #239 on: 26 / April / 2015, 20:21:58 »
The bug I found was in virtual_buttons

buf isn't initialized before
Code: [Select]
                if (keymap[i].hackkey == TS_UP_DN_BUTTON)
                {
                     draw_string(x1+4, y1+ofst, buf, cl);
I'm not really clear how this was supposed to work, the key names are printf format strings. This appears to be related to the exposure override in video stuff, which as far as I can tell is unique to this cam. For my test I just used a fixed string.
Don't forget what the H stands for.

 

Related Topics