IXUS 240/ELPH 320 HS Porting thread - page 4 - DryOS Development - CHDK Forum
supplierdeeply

IXUS 240/ELPH 320 HS Porting thread

  • 286 Replies
  • 68789 Views
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #30 on: 27 / May / 2013, 03:46:50 »
Advertisements
Just bought a 240HS and found this thread miraculously (just heard about CHDK looking for how to do a time lapse  :haha).
So I arrived here…

First things first, I would like to thank you for the work done!
I would like to try this fw but don´t know if it is stable enough or not…
Could someone tell me the actual features available at this time with the port CHDK? (time lapse?)

Guys, just let me encourage you to keep working on such a good feature that will help the entire community!!!
 :)

*

Offline Uwe

  • *
  • 18
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #31 on: 27 / May / 2013, 05:25:45 »
Some other points to check:
- Firmware modemap table is not complete, check the messages in stubs_entry.S.  Instructions available here:
http://chdk.wikia.com/wiki/Adding_support_for_a_new_camera
Ok, this need to be done

- Did you enable movie_rec hook?  extended video time, and set quality video patches are implemented. Could you tested?
tested successful

- Some scripts for testing are available here: http://chdk.wikia.com/wiki/Testing
looks good, all "ok"

As it looks like you are planning to be around CHDK for a while,  you might want to take a few quiet minutes and read through this post and some of the included links :
link> Questions about RAW ?
aaahh :) okay. good, so no problem in the port


I would like to try this fw but don´t know if it is stable enough or not…
The port is not stable, but you can simply try it out.
CHDK is not flashed to the camera but loaded from the memory card: http://chdk.wikia.com/wiki/FAQ#Q._Can_CHDK_damage_your_camera.C2.A0.3F
Just look for your firmware version (http://chdk.wikia.com/wiki/FAQ#Q._How_can_I_get_the_original_firmware_version_number_of_my_camera.3F ) if its 101a or 102a, you can try to load one of our current debug builds and look if its working (+help testing maybe).
Otherwise, it would be nice if you can upload a dump of your firmware version: http://chdk.wikia.com/wiki/Canon_Basic/Scripts/Dumper




Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #32 on: 27 / May / 2013, 06:15:02 »
...
[

thanks for your resposes!
I will check my fw and prepare a SD with the executable.

To last and quick questions:
1)How do you currently move between the menus since we dont have the touchscreen running well?
and
2)can you list the actual working new features available with this mod?

THANKS AGAIN MATE! 8)

*

Offline Uwe

  • *
  • 18
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #33 on: 27 / May / 2013, 06:18:10 »
Okay, I have the menu working completely
Touchscreen is running.
From my feelings we have little problems with the accuracy of the buttons on the right side of the screen, but its working.
« Last Edit: 27 / May / 2013, 06:25:14 by Uwe »


Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #34 on: 27 / May / 2013, 07:22:52 »
So, I should try today and give you feedback.

My only concern now is: which new functions does it currently offer to the camera?
I cannot get any list with new funcionalities (as it exists for other models)

Danke! ;)

*

Offline Uwe

  • *
  • 18
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #35 on: 27 / May / 2013, 07:27:11 »
I've only tested RAW, video and scripting so far. It's running since yesterday, so I have no idea what else is working or not, please test it :)


und bitte :P

Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #36 on: 27 / May / 2013, 09:01:03 »
Thank you for your interest!
Where should I get the files from?
From this thread or from the wiki?
I´m really willing to start!!!!!!!!!!!! :lol

*

Offline Uwe

  • *
  • 18
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #37 on: 27 / May / 2013, 09:05:45 »
What's your firmware version?
if its 102a, use my build on page 3 of this thread. I can also post a build for 101a, but if its something other it would be nice if you could upload a firmware dump.


*

Offline Uwe

  • *
  • 18
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #38 on: 27 / May / 2013, 13:24:22 »
I think i discovered a problem:
If anyone could please have a look at the two pictures in the attachment. Both are from the same shoot. IMG_0374.JPG is the file that comes out of the canon firmware and IMG_0374_from_dng.JPG is a jpg version of the chdk .dng file.
This happens not all the time, but really often. Any idea, where the problem could be?

*

Offline nafraf

  • *****
  • 1308
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #39 on: 27 / May / 2013, 14:23:08 »
This happens not all the time, but really often. Any idea, where the problem could be?
What if you shoot using P mode?

RAW buffers addresses seems to be right (lib.c)
I asked about P mode, because a similar bug exists in SX260, shooting raw in AUTO mode.

I updated my code with your patches, and clean up lib.c
« Last Edit: 27 / May / 2013, 14:29:48 by nafraf »

 

Related Topics