IXUS 240/ELPH 320 HS Porting thread - page 17 - DryOS Development - CHDK Forum supplierdeeply

IXUS 240/ELPH 320 HS Porting thread

  • 312 Replies
  • 93954 Views
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #160 on: 08 / December / 2013, 00:02:31 »
Advertisements
Continued from #159

Initial test results for Ixus 240-100c Camera #3 for Play and Record.

See attached file.

Comments, ???.

H-H
« Last Edit: 08 / December / 2013, 00:04:42 by Hardware_Hacker »

*

Offline srsa_4c

  • ******
  • 4426
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #161 on: 08 / December / 2013, 09:12:19 »
Comments
I'm sure you'll get more comments/help if you
- upload that 100c dump
- publish your source

*

Offline reyalp

  • ******
  • 13450
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #162 on: 08 / December / 2013, 15:04:21 »
I think I have found one problem, the Ixus 240-100c camera are "Different" in some way.
It is very unlikely that the firmware is different if the version is the same. Far more likely it's it a difference in camera settings or something like that.
Quote
I think I need to try to a Dump for each camera, see attached files, the difference here is that
The cameras store various stuff in the onboard flash, so you will see some differences in the dump even if the actual firmware code is identical.
Quote
I just swapped the SD Cards and repeated the test. Camera #3 is still the camera that is Ok.
Check that all the canon settings are identical.
Don't forget what the H stands for.

*

Offline JvdP

  • ***
  • 174
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #163 on: 09 / December / 2013, 10:02:50 »
Does somebody know how to adapt the script to the 240?
I suppose I need to change the "click "shoot_full""
Should work if you change :

Code: [Select]
        click "shoot_full"
        sleep l
        click "shoot_full"

to

Code: [Select]
        press "video"
        sleep 500
        release "video"
        sleep l
        press "video"
        sleep 500
        release "video"

But you might want to take a look at : http://chdk.setepontos.com/index.php?topic=10864 - a more sophisticated script with what has prove to be the fastest motion detection response.
Your script looks much more like what I was trying to go for. I didn't find it using Google though...

One more question with regards to video. I'm trying to adapt one of the Continuous Video Scripts to my 240 HS but I can't manage. None of the scripts seem to work since none manage to get the camera to record. Any tips?

Script 2 and Script 1a work but just take a photo instead of video. So I thought I just change the:

Code: [Select]
click "shoot_full"
to
Code: [Select]
press "video"
sleep 500
release "video"

But this didn't work.
« Last Edit: 09 / December / 2013, 10:09:31 by JvdP »


*

Offline srsa_4c

  • ******
  • 4426
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #164 on: 09 / December / 2013, 11:51:29 »
None of the scripts seem to work since none manage to get the camera to record. Any tips?
Try
Code: [Select]
post_levent_to_ui("PressMovieButton")
post_levent_to_ui("UnpressMovieButton")
to mimic a touch on the virtual button. I'm not sure whether this will work though, can't try it.
CHDK can only simulate press/click/release on physical buttons.

*

Offline JvdP

  • ***
  • 174
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #165 on: 10 / December / 2013, 03:15:24 »
This doesn't work for me, I get a uBASIC:10 Parse err

Quote
@title MultiMovie 1a
@param x minutes per file
@default x 10
press "shoot_half" 
sleep 2000
release "shoot_half"
:loop
   print "segment started..."
        post_levent_to_ui("PressMovieButton")
        post_levent_to_ui("UnpressMovieButton")
   s=get_tick_count
   do
      sleep 500
   until x<=((get_tick_count-s)/60000 )
        post_levent_to_ui("PressMovieButton")
        post_levent_to_ui("UnpressMovieButton")
   do
      sleep 100
   until get_movie_status=1
goto "loop"
end

*

Offline msl

  • *****
  • 1276
  • A720 IS, SX220 HS 1.01a
    • CHDK-DE links
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #166 on: 10 / December / 2013, 05:56:16 »
The function 'post_levent_to_ui' is not available for uBASIC. You must rewrite the script for Lua.

msl
CHDK-DE:  CHDK-DE links

*

Offline JvdP

  • ***
  • 174
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #167 on: 10 / December / 2013, 06:26:30 »
The function 'post_levent_to_ui' is not available for uBASIC. You must rewrite the script for Lua.

msl
I thought so. Thank you for the confirmation!


*

Offline JvdP

  • ***
  • 174
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #168 on: 25 / December / 2013, 04:56:28 »
I've upgraded to the 1.3.0 version from the autobuild, but I'm still having rebooting issues. Whenever reboot is called from script, the camera just shuts down but doesn't start up. Has anybody managed a reboot from script with this camera?

Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #169 on: 27 / December / 2013, 16:25:01 »
Hi,

I'm a complete newbie to CHDK and just get hold of an ixus 240HS firmware 1.00d. These are now getting really cheap and I'd like to test some quadcopter-based aerial photography.

Is there any chance I could get a test release, give it a try and help you out by reporting ?

By the way, wonderful work and thanks to all the developpers for allowing us, humble newbies, to use chdk.

 

Related Topics