IXUS 240/ELPH 320 HS Porting thread - page 20 - DryOS Development - CHDK Forum

IXUS 240/ELPH 320 HS Porting thread

  • 286 Replies
  • 68792 Views
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #190 on: 17 / January / 2014, 20:38:09 »
Advertisements
Continued from #189

Attached, Source for my build(s) of 240-100c and 240-100d

(*\CHDK-Shell-3v44\trunk\trunk-3314\platform\ixus240_elph320hs\sub\*)

A Note in regard to the (old) 240-100d:-

http://chdk.setepontos.com/index.php?topic=9005.msg107715#msg107715

Since the above post the 240-100d was re-ported, by hand, so could
it still could have some porting errors. but seems to work OK for me.

H_H
« Last Edit: 17 / January / 2014, 21:10:33 by Hardware_Hacker »

*

Offline JvdP

  • ***
  • 174
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #191 on: 21 / January / 2014, 16:24:49 »
I've been looking around a little but can't find an answer. How do I run my 240 HS with the battery door open?

Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #192 on: 21 / January / 2014, 16:39:43 »
I've been looking around a little but can't find an answer. How do I run my 240 HS with the battery door open?
http://chdk.setepontos.com/index.php?topic=5744.0
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline JvdP

  • ***
  • 174
IXUS 240/ELPH 320 HS Porting thread
« Reply #193 on: 21 / January / 2014, 16:59:14 »
Thanks for the quick reply, but my camera doesn't load with the battery door open at all.

Since this is hardware related I posted it in this thread hoping that somebody else would have tested it on this P&S.
« Last Edit: 21 / January / 2014, 17:07:01 by JvdP »


Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #194 on: 21 / January / 2014, 17:48:38 »
Thanks for the quick reply, but my camera doesn't load with the battery door open at all.
That's normal.

Quote
Since this is hardware related I posted it in this thread hoping that somebody else would have tested it on this P&S.
The code described in the other thread should do what you need - the door switch can usually be masked in software.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline JvdP

  • ***
  • 174
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #195 on: 22 / January / 2014, 07:40:01 »
...
That's normal.

...
The code described in the other thread should do what you need - the door switch can usually be masked in software.
OK, thanks, then I misunderstood.

There is no software way to start the camera with the battery door open? Then I suppose the best thing I could do is temporarily "fool" the tiny switch at the door.

Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #196 on: 22 / January / 2014, 09:03:44 »
...
That's normal.
...
The code described in the other thread should do what you need - the door switch can usually be masked in software.
OK, thanks, then I misunderstood. There is no software way to start the camera with the battery door open? Then I suppose the best thing I could do is temporarily "fool" the tiny switch at the door.
Defeating the door switch is the easy way and quicklest way.  But if you want to do some testing, it's possible to upgrade the actual CHDK port for the camera so that it ignores the battery switch.  Several other CHDK ports already work that way.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #197 on: 02 / March / 2014, 08:53:15 »
Any news on this port?
I just want to shoot interval pics with the 240HS. Has anyone a working CKDK for the 100c?

thx Fsg


*

Offline nafraf

  • *****
  • 1308
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #198 on: 02 / March / 2014, 13:26:58 »
@fsg4u
To port 100c, firmware dump is needed.
Could you dump the fw, upload it to a file share server and post the link here?
http://chdk.wikia.com/wiki/Canon_Basic/Scripts/Dumper
Please, don't miss the note: "read this first : Canon_Basic Card_Setup " at top of wikia page :)


*

Online reyalp

  • ******
  • 12649
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #199 on: 09 / August / 2014, 20:23:25 »
A user on IRC reported the ixus240/elph320 101a crashes shortly after startup if you boot using firm update. This happens with both stable and trunk.  Autoboot works OK.
Error is
ASSERT!! StartupEeko.c Line 84

It would be interesting if anyone else with this camera (with the same or different firmware) can start with firm update.

The same error appears to have been encountered with script reboot() http://chdk.setepontos.com/index.php?topic=9005.msg104925#msg104925 which isn't to surprising since that uses some of the same code.
Don't forget what the H stands for.

 

Related Topics