IXUS 240/ELPH 320 HS Porting thread - page 23 - DryOS Development - CHDK Forum supplierdeeply

IXUS 240/ELPH 320 HS Porting thread

  • 312 Replies
  • 130451 Views
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #220 on: 20 / March / 2015, 00:08:34 »
Advertisements
Here it goes!
http://we.tl/CNoqQirdX1

*

Offline srsa_4c

  • ******
  • 4451
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #221 on: 20 / March / 2015, 16:24:22 »
Thanks for your answer!!
Of course! I really need this release!! I already did the firmware dump. I tried to attach it here, but the file is too large, and I can't find upload instructions.
I'm willing to test the port! No problem!
Okay, here's a test version (in the .zip file). Note that you need to use the "bootable SD card" method because a ps.fi2 file needed for the "firmware update" boot is not included.

Instructions for testing various things are on the following page: http://chdk.wikia.com/wiki/Testing
I don't actually expect more issues than the already known ones (if any), so I don't need a detailed report about things that work.
What I do need:
- failures, if any (especially when something causes the cam to crash)
- result of mftest.lua (script is included in zip, described on the testing page)
- result of isobase.lua (script is included in zip, described on the testing page)
- result of vidtest.lua (script is included in zip, description is here)

Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #222 on: 23 / March / 2015, 11:37:01 »
Thanks!! I'll be posting results.

*

Offline fe50

  • ******
  • 3147
  • IXUS50 & 860, SX10 Star WARs-Star RAWs
    • fe50
Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #223 on: 29 / March / 2015, 05:06:18 »
Here it goes!
http://we.tl/CNoqQirdX1
Unfortunately, the download is no longer available...


Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #224 on: 18 / April / 2015, 19:30:12 »
Hi! After a short discussion on your fb page, I was suggested to post here, so I do :)
I have an IXUS 240 HS, CHDK installs fine via Stick, seems to work but... I have no "CHDK" (AKA <Alt>) button on shooting mode.
I think it's needed to start the badpixels.bin thing and then finally have .dng files (cannot open .crw).
SD is blocked; button is on touchscreen in playback mode but disappears from shooting mode.
Perhaps a bug? I tried 1.3 build April 15. Thanks again!

Lorenzo

Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #225 on: 18 / April / 2015, 20:30:58 »
Hi! After a short discussion on your fb page, I was suggested to post here, so I do :)
I have an IXUS 240 HS, CHDK installs fine via Stick, seems to work but... I have no "CHDK" (AKA <Alt>) button on shooting mode.
Note : this is a touch screen camera.  OP confirmed that he see a CHDK button in playback mode and that he is using "SD Card Lock" for booting.

I found an ELPH320 post from 18 months ago that speculated  : "I guess its possible the LCD dimensions are wrong in the CHDK code such that the bottom of the CHDK display area is off screen?"  There new was really an answer to that.  I can't see anything else wrong in the platform kbd.c code.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #226 on: 19 / April / 2015, 05:55:19 »
Update: I gave release 1.4 (experimental) a try: firmware loads, CHDK button is there in both playback and shooting (or "record", as is also referred to) mode, same position, where expected; but camera freezes immediately when I push the button. Therefore, I'd report 1.4 as unusable (for now!) on this specific touchscreen Ixus.

Lorenzo

Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #227 on: 19 / April / 2015, 08:19:13 »
Update: I gave release 1.4 (experimental) a try: firmware loads, CHDK button is there in both playback and shooting (or "record", as is also referred to) mode, same position, where expected; but camera freezes immediately when I push the button. Therefore, I'd report 1.4 as unusable (for now!) on this specific touchscreen Ixus.
Does the button work correctly in Playback mode?  ( i.e the crash only happens when you touch it in Shooting mode)
Ported :   A1200    SD940   G10    Powershot N    G16


Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #228 on: 19 / April / 2015, 08:40:34 »
No, it doesn't work in plaback mode too, freezes the camera in both modes. (Always speaking about experimental version 1.4, eh).

Lorenzo

Re: IXUS 240/ELPH 320 HS Porting thread
« Reply #229 on: 19 / April / 2015, 09:01:56 »
No, it doesn't work in plaback mode too, freezes the camera in both modes. (Always speaking about experimental version 1.4, eh).
Thanks.

There were substantial changes done to the kbd.c file in every camera under 1.4.0.   Obviously that did two things to the IXUS240 - it "fixed" the missing CHDK on-screen button in shooting mode but "broke" the actions that happen when you press it.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics