G7 firmware update problem - General Help and Assistance on using CHDK stable releases - CHDK Forum

G7 firmware update problem

  • 8 Replies
  • 5396 Views
G7 firmware update problem
« on: 31 / March / 2008, 21:19:05 »
Advertisements
Hi:

I've read all updating instructions carefully, but I can not do it.
I have G7 with 1.00i firmware... I've tested downloading:

- Fingalo 124, Nov. 26th: zSHARE - pre14-g7-100i-148.zip (verified ok)
- Fingalo 124, Nov. 23rd: http://hem.passagen.se/fsmmal/CHDK/pre14.grand148.md.cln.zsm-g7-100i-124.zip (verified ok)
- G7 fw v1.00i SDM (Stereo Data Maker) version 1.40
- http://stereo.jpn.org/eng/sdm/file/1.50-148-g7-100i-57.zip

All "1.00i" coincidences in downloads page...

I insert two files in zip in root directory... but when I go to menu of the camera (play mode, or even photo mode), I do not see any "firmware" menu as the tutorial says.

What might have i done bad ?

thank you

*

Offline whim

  • ******
  • 2046
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: G7 firmware update problem
« Reply #1 on: 01 / April / 2008, 03:49:24 »
Hi

Are you really sure you've checked the entire Canon menu for the firmware upgrade option ?
(On my A620) it's all the way down on the first tab page of the base menu, you'll have to
scroll down. Menu is accessible through the menu button (sounds ridiculous, but just making
sure your not confusing it with the Func/set menu).
Otherwise, make sure you read these two Wiki pages:

FAQ: FAQ - CHDK Wiki

and

for auto-booting: Bootable SD card - CHDK Wiki

good luck

wim

edit: and, BTW: CHDK is not a firmware update, it only uses the part of the firmware update capability of the camera
        to load itself in addition to the original Canon firmware

« Last Edit: 01 / April / 2008, 03:52:58 by whim »

Re: G7 firmware update problem
« Reply #2 on: 01 / April / 2008, 04:21:54 »
Yes, I'm sure... besides the "func/set" button does not work in "play mode"  :P

I have tested with 4 versions of files... I can not see that menu option at all...
I'm sure to put both files in ROOT directory

I can make you a video of what I do if you want :P

If my firmware is 1.00i i must to pick one those files, mustnt i?

*

Offline whim

  • ******
  • 2046
  • A495/590/620/630 ixus70/115/220/230/300/870 S95
Re: G7 firmware update problem
« Reply #3 on: 01 / April / 2008, 07:31:13 »
Hi

As I already mentioned, I don't have a G7, so all i say is just 'shooting in the dark'
but, let's check a couple more things:

what's your SD card ? If it is 4GB or bigger, check the formatting: CHDK doesn't particularly like FAT32,
which is the default format for cards > 2GB. If your working with these large cards, experiment with the
card that came with your cam (dunno - 16, 32 ? MB ) These should work fine.

ok that was it for the moment -

wim


Re: G7 firmware update problem
« Reply #4 on: 01 / April / 2008, 09:01:36 »
Deleted
« Last Edit: 22 / April / 2008, 15:40:59 by Barney Fife »
[acseven/admin commented out: please refrain from more direct offensive language to any user. FW complaints to me] I felt it imperative to withdraw my TOTAL participation. Nobody has my permission, nor the right, to reinstate MY posts. Make-do with my quoted text in others' replies only. Bye

*

Offline wontolla

  • ****
  • 413
  • S3 & G9 & A720
Re: G7 firmware update problem
« Reply #5 on: 01 / April / 2008, 13:09:31 »
Are you sure you go directly from "off" to "playback mode"?

In my S3, if you go to "photo mode" first and then to "playback mode", the firmware option does not appear in the menu.

*

Offline carlos

  • **
  • 63
  • A640
Re: G7 firmware update problem
« Reply #6 on: 01 / April / 2008, 13:58:28 »
naiad,

You seem to know what you're doing; I felt challenged, then found these clear and simple instructions:

RAW - on the Canon G7 - using CHDK card Firmware

A640 up and running in 5 mins.  :D

Help you? Maybe ... just trying!

Best,

carlos
« Last Edit: 01 / April / 2008, 14:01:01 by GrAnd »

Re: G7 firmware update problem
« Reply #7 on: 01 / April / 2008, 15:01:33 »
well, I made some "progress"...found out that WinXP simply refuses to format an 8GB SDHD card as fat16. Even if the format command says that is what it is doing. Won't do it. So I got out an old SD card and formatted that and put the diskboot.bin from allbest .57 on it and used the bootdisk tool and checked the mbr with a hexeditor and it looks ok...the camera a650 will not boot at all with this card in it in wp mode. It works ok in unlocked, but is dead when the card is locked.vvv thanks

Will someone please put up exactly the code and hardware that they are using and the *exact* procedures and directory-listing that they are using to get this to work with their a650?

thanks


*

Offline carlos

  • **
  • 63
  • A640
Re: G7 firmware update problem
« Reply #8 on: 01 / April / 2008, 16:07:27 »
Thanks for the edit, GrAnd ... those eyes are everywhere!   :blink:

carlos

 

Related Topics


SimplePortal 2.3.6 © 2008-2014, SimplePortal