SD550 USB Remote Problem - page 4 - General Help and Assistance on using CHDK stable releases - CHDK Forum

SD550 USB Remote Problem

  • 48 Replies
  • 6483 Views
Re: SD550 USB Remote Problem
« Reply #30 on: 27 / December / 2012, 23:39:03 »
Advertisements
Has something been changed a few months back?
Nothing has changed - that's how its supposed to work. The USB icon indicates the remote function is enabled not the status of the port itself.
Actually, get_usb_bit() always returns 0 in the current code for the S2IS and S3IS (not checked the rest), so, assuming that USB remote worked in CHDK 1.0, restoring that functionality will need testers who have the camera.
The original post by Pauls9 seemed to be commenting on the USB icon / text that CHDK displays when the USB remote is enabled. My response was that it hadn't changed.

Just looked briefly at the S2IS and S3IS.   The get_usb_bit() for those cameras returns 0 on purpose.  I suspect that's because the whole wait_until_remote_button_is_released() function was never implemented for those cameras in 1.0 (its all commented out) so I didn't try to implement any of the USB remote code.  However, it looks like the 1.0 code for my_kbd_read_keys() has all that's needed to implement get_usb_bit() - I could probably just update it and wait until somebody comes along to test it.

Update :  the  ixus55_sd450 & ixus60_sd600 code also have get_usb_bit() returning a hard coded zero.  Might not be as easy to fix those ones.  The rest of the cameras look okay.

« Last Edit: 28 / December / 2012, 00:36:01 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline Pauls9

  • **
  • 60
  • S3 IS
Re: SD550 USB Remote Problem
« Reply #31 on: 28 / December / 2012, 03:55:17 »
Thanks for clarifying the purpose of the <USB> display, waterwingz - my misunderstanding.

However, my main point was that the USB remote worked on the S3 up until the new remote functionality was introduced (unless this is a coincidence). Testing with the versions I have available: 707, 940, 1165, 1242, 1319, 1491 work; 2165, 2407 don't.

Or should I select something other than Switch Type OnePush, Control Mode Normal for a simple push button? (I have tried other combinations as well).

Re: SD550 USB Remote Problem
« Reply #32 on: 28 / December / 2012, 08:45:10 »
However, my main point was that the USB remote worked on the S3 up until the new remote functionality was introduced (unless this is a coincidence). Testing with the versions I have available: 707, 940, 1165, 1242, 1319, 1491 work; 2165, 2407 don't.
You are correct about the S3 USB remote code no longer working.  When the new USB functionality was added, there were several cameras with what looked like "broken"  USB remote implementations, including the S3. I did not attempt to change those cameras at the time as I had no way to test them.  I think I can fix the S3 if you are willing to test the fixed version.   

I'll add a note to the wiki pages for the other cameras stating that the USB remote code does not work and anyone willing to help test should post on the appropriate porting thread.


 
Ported :   A1200    SD940   G10    Powershot N    G16

Re: SD550 USB Remote Problem
« Reply #33 on: 28 / December / 2012, 09:25:55 »
Updated version with new USB remote for the S3 available here :  https://www.box.com/s/7r4re2tyydcxt0chv2ld

Please post any results - positive or negative

I'll look at the SD550 next.
Ported :   A1200    SD940   G10    Powershot N    G16


*

Offline Pauls9

  • **
  • 60
  • S3 IS
Re: SD550 USB Remote Problem
« Reply #34 on: 28 / December / 2012, 09:38:22 »
Updated version with new USB remote for the S3 available here :  https://www.box.com/s/7r4re2tyydcxt0chv2ld

Please post any results - positive or negative

I'll look at the SD550 next.
That was quick!

Camera starts in record mode, then switches to replay. Won't go back to record or switch off. :(

I'm off for a post-Christmas break shortly, so no internet for a week.

Re: SD550 USB Remote Problem
« Reply #35 on: 28 / December / 2012, 09:50:32 »
Firmware Version: 1.00G
@MrSim17 :  I've build tjhe old version of CHDK for the SD550 from the 1.0.0 trunk.

https://www.box.com/s/uv7ynm9lx58x1i7m9987

It has the USB remote code that existed prior to the V2 update.   Please load this and test - if it works then I can use that to fix the current version for your camera.
Ported :   A1200    SD940   G10    Powershot N    G16

Re: SD550 USB Remote Problem
« Reply #36 on: 28 / December / 2012, 10:00:20 »
Camera starts in record mode, then switches to replay. Won't go back to record or switch off. :(
Hmmm ... looks like the _kbd_read_keys_r2 might be needed after all.

Try this (same link - new code) : https://www.box.com/s/7r4re2tyydcxt0chv2ld

Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline Pauls9

  • **
  • 60
  • S3 IS
Re: SD550 USB Remote Problem
« Reply #37 on: 28 / December / 2012, 10:14:06 »
Camera starts in record mode, then switches to replay. Won't go back to record or switch off. :(
Hmmm ... looks like the _kbd_read_keys_r2 might be needed after all.

Try this (same link - new code) : https://www.box.com/s/7r4re2tyydcxt0chv2ld


That's working. :) With Switch Type OnePush, Control Mode Normal, you'd expect it to focus on press and shoot on release?


Re: SD550 USB Remote Problem
« Reply #38 on: 28 / December / 2012, 10:27:10 »
That's working. :)
:xmas
Quote
With Switch Type OnePush, Control Mode Normal, you'd expect it to focus on press and shoot on release?
Yup.

I'll post the patch for inclusion in the autobuild.  One down,  four to go.

« Last Edit: 29 / December / 2012, 23:59:07 by waterwingz »
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline Pauls9

  • **
  • 60
  • S3 IS
Re: SD550 USB Remote Problem
« Reply #39 on: 28 / December / 2012, 10:37:13 »
Great! Thanks for the quick response!

 

Related Topics