G15 Porting thread - page 2 - DryOS Development - CHDK Forum

G15 Porting thread

  • 82 Replies
  • 25741 Views
Re: G15 Porting thread
« Reply #10 on: 17 / April / 2013, 04:13:30 »
Advertisements
c10ud, thanx a lot! Need one thing from g15 chdk. Change default movie bitrate to wider.

*

Offline c10ud

  • ***
  • 245
Re: G15 Porting thread
« Reply #11 on: 17 / April / 2013, 09:56:59 »
g15 100b alpha build attached, please test and report back (at your own risk, as usual).

see my first post for known issues / TODOs

UPDATE: attachment removed since G15 is going to be included in CHDK main repository soon
« Last Edit: 22 / April / 2013, 06:35:25 by c10ud »

Re: G15 Porting thread
« Reply #12 on: 17 / April / 2013, 15:19:07 »
The G15 has a little problem with smooth panning.
I guess you would have to tell us exactly what kind of problem the G15 has with panning?

in this video it is quiet good visible.
When panning to the right, you will see the house shocking.

in this video you also see the verical lines of the wall and mirror shocking.

Maybe it is due to rolling shutter or something else?

Re: G15 Porting thread
« Reply #13 on: 17 / April / 2013, 16:35:09 »
Maybe it is due to rolling shutter or something else?
I'm not too familiar with shooting P&S camera videos but what I see looks more like the image stablization in your camera fighting the panning motion?  Is it possible to turn IS off in video mode?
Ported :   A1200    SD940   G10    Powershot N    G16


Re: G15 Porting thread
« Reply #14 on: 17 / April / 2013, 19:01:50 »
g15 100b alpha build attached, please test and report back (at your own risk, as usual).
see my first post for known issues / TODOs
It's working! Zebra, edges and histogram displays.  But their settings do not work. Not all. Video parameters are not active.

*

Offline c10ud

  • ***
  • 245
Re: G15 Porting thread
« Reply #15 on: 18 / April / 2013, 06:34:50 »
g15 100b alpha build attached, please test and report back (at your own risk, as usual).
see my first post for known issues / TODOs
It's working! Zebra, edges and histogram displays.  But their settings do not work. Not all. Video parameters are not active.
As I told to nafraf, I mimicked SX50's movie_rec task and I'm not really sure if it worked or not: recording a few seconds with quality=1 and 99 didn't show a significant difference in quality (if any at all) while VLC reported a different bitrate (less quality, more bitrate ???). I'm not really sure on how to interpret this data..

Re: G15 Porting thread
« Reply #16 on: 18 / April / 2013, 06:42:51 »
To estimate the bit rate change need to record at least 10 seconds. In other matters, and so it is clear that while the bit rate does not change. There are chances that once this happens?

ps: Sorry for my English, I write through google translate. :)

*

Offline c10ud

  • ***
  • 245
Re: G15 Porting thread
« Reply #17 on: 18 / April / 2013, 09:56:10 »
To estimate the bit rate change need to record at least 10 seconds. In other matters, and so it is clear that while the bit rate does not change. There are chances that once this happens?

ps: Sorry for my English, I write through google translate. :)
further testing @ 640x480 show:
- 6 seconds with video quality=1: crappy video, size: 1-2MB
- 6 seconds with video quality=99: good video, size: 10-11MB

I guess video quality overrides _are_ working then, probably they're ignored with FULL HD resolution, or their impact is much less visible..?

Also, CHDK ui shows nonsense bitrate (like, negative KB/s), but I guess that's another story ;)


Re: G15 Porting thread
« Reply #18 on: 18 / April / 2013, 10:47:44 »
Damn, bad if we can not increase the bitrate in full hd. I was hoping for when I bought this camera.

*

Offline c10ud

  • ***
  • 245
Re: G15 Porting thread
« Reply #19 on: 22 / April / 2013, 06:46:02 »
OK,
since it seems there's no issue here, I asked for inclusion in main trunk and autobuild (BETA status):

http://chdk.setepontos.com/index.php?topic=650.msg99631#msg99631

 

Related Topics