G15 Porting thread - page 4 - DryOS Development - CHDK Forum

G15 Porting thread

  • 82 Replies
  • 25323 Views
*

Offline philmoz

  • *****
  • 3071
    • Photos
Re: G15 Porting thread
« Reply #30 on: 30 / April / 2013, 20:49:16 »
Advertisements
I still have the G15 so i tested this: it looks like G15 suffers from the same bug, from the shoot button click to the camera being responsive again about 30seconds pass with Dark frame subtraction on and off
I suspect the G15 was a c&P from the SX50,  which in turn was a C&P from the SX240/SX260.   The release date of those cameras are the closest to the G15/SX50 of any ported camera but they are at least  six months older.

Can you try this value and let me know what happens:
Code: [Select]
static long *nrflag = (long*)(0xC39C);

Phil.
This value makes the dark frame override working, thanks phil

SVN updated with fix (both trunk and release-1.1).

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)

Re: G15 Porting thread
« Reply #31 on: 01 / May / 2013, 09:45:16 »
SVN updated with fix (both trunk and release-1.1).
Looking at the overnight update,  the sigfinder changes hit more cameras than just the G15 & SX50.

For my A1200,  the change is only to the comments - the nrflag value stayed the same.

Were any of the other cameras changed such that they need to be retested?
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline philmoz

  • *****
  • 3071
    • Photos
Re: G15 Porting thread
« Reply #32 on: 01 / May / 2013, 15:58:39 »
SVN updated with fix (both trunk and release-1.1).
Looking at the overnight update,  the sigfinder changes hit more cameras than just the G15 & SX50.

For my A1200,  the change is only to the comments - the nrflag value stayed the same.

Were any of the other cameras changed such that they need to be retested?

The IXUS125 (ELPH110) 1.01a had the same nrflag detection problem as the SX50/G15.
That's the only one I can see where the capt_seq.c value now differs from the stubs_entry.S value.

Phil.
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)

*

Offline TD

  • *
  • 3
Re: G15 Porting thread
« Reply #33 on: 04 / May / 2013, 15:25:27 »
Should the Zebra mode work?
I only get distorted noise when activated.


*

Offline c10ud

  • ***
  • 245
Re: G15 Porting thread
« Reply #34 on: 05 / May / 2013, 11:25:53 »
Should the Zebra mode work?
I only get distorted noise when activated.
just tried with current trunk and it's working, I am not sure on what you're experiencing

*

Offline TD

  • *
  • 3
Re: G15 Porting thread
« Reply #35 on: 06 / May / 2013, 02:42:30 »
Thanks for the info.
I just switched from the DE trunk to g15-100b-1.1.0-2760-full_BETA and now the basic zebra mode works.
But it still ignores the switches - eg. changing of Zebra mode to Blink 1, or to solid with rgb, ...

*

Offline c10ud

  • ***
  • 245
Re: G15 Porting thread
« Reply #36 on: 06 / May / 2013, 05:59:17 »
Thanks for the info.
I just switched from the DE trunk to g15-100b-1.1.0-2760-full_BETA and now the basic zebra mode works.
But it still ignores the switches - eg. changing of Zebra mode to Blink 1, or to solid with rgb, ...
You may be finding old chdk bugs or incompatibilities (?) between g15 and "old" chdk, I suggest you get the 1.2 release, I tried all zebra modes and they work ok

*

Offline TD

  • *
  • 3
Re: G15 Porting thread
« Reply #37 on: 08 / May / 2013, 13:40:25 »
Thanks for your support.
The recent branch works like it should.
Great work.


Re: G15 Porting thread
« Reply #38 on: 15 / May / 2013, 17:16:06 »
just got my G15 in the mail yesterday and was upset to learn it's got the 100.e firmware on it. One of the only reasons I bought this thing was to replace my DSLR on backpacking trips, and it's going to be pretty useless with only a 15 second shutter and no bulb mode :[

Any idea how long it might be until CHDK is ported to 100.e ??

Re: G15 Porting thread
« Reply #39 on: 15 / May / 2013, 17:37:40 »
Any idea how long it might be until CHDK is ported to 100.e ??
link>CHDK FAQ : My camera isn't ported yet

However,  if you can dump your camera firmware, upload to a file sharing site, and post the link here you might things can happen.
Ported :   A1200    SD940   G10    Powershot N    G16

 

Related Topics