A2400 porting thread - page 5 - DryOS Development - CHDK Forum supplierdeeply

A2400 porting thread

  • 96 Replies
  • 29832 Views
Re: A2400 porting thread
« Reply #40 on: 28 / March / 2013, 18:39:54 »
Advertisements
One Push - bracket - take only one shot (I will test again).
In USB remote bracketing mode,  the camera will take one picture per button press. It will adjust the exposure at each subsequent button press, alternating plus and minus. This will continue until the button has not been pressed for 5 seconds, at which point the whole process will reset.
Ported :   A1200    SD940   G10    Powershot N    G16

*

Offline nafraf

  • *****
  • 1308
Re: A2400 porting thread
« Reply #41 on: 29 / March / 2013, 05:17:15 »
One Push - Video - not work. Some times take photo, no video. Sometime crash - black screen.
Please test with this version: a2400-100e-1.2.0-prealpha04.zip

If camera crashes, please post the ROMLOG.LOG file.
The romlog can be saved from the CHDK menu, using "miscellaneous stuff->Debug Parameters->Save ROM crash log"

Re: A2400 porting thread
« Reply #42 on: 29 / March / 2013, 16:09:52 »
I tested a2400-100e-1.2.0-prealpha04.zip
- The main ON switch working now.
- USB remote - video - It is working now.

"CHDK GUI sometimes flashes"
1. First step - I switch to Preview mode.
2. Second step - I switch to Capture mode.
-chdk gui flashes 3 times. I thing camera redraw all chdk items on the display.
(first redraw after 1 sec, second redraw after cca 3 sec, Canon firmware hide some info from display, third redraw after cca 4 sec)
It is normal ? I have only one type of camera :) . I don`t compare to other.

Re: A2400 porting thread
« Reply #43 on: 29 / March / 2013, 17:07:12 »
I tried create basic script to change zoom property. ... set_zoom a.
Script is working, but after script acomplished, manual zoom not working.
I must switch to Prieview mode then back to Capture mode, then manual zoom work again.
Is it normal or bug in my .bas script ?


Re: A2400 porting thread
« Reply #44 on: 30 / March / 2013, 16:29:42 »
- chdkptp connection + liveview?
I tested ptpCamGUI 2.0.134
- connection, communication, take photo, record video, zoom are working.
how I do livieview ? 

*

Offline nafraf

  • *****
  • 1308
Re: A2400 porting thread
« Reply #45 on: 30 / March / 2013, 20:41:55 »
"CHDK GUI sometimes flashes"
1. First step - I switch to Preview mode.
2. Second step - I switch to Capture mode.
-chdk gui flashes 3 times. I thing camera redraw all chdk items on the display.
(first redraw after 1 sec, second redraw after cca 3 sec, Canon firmware hide some info from display, third redraw after cca 4 sec)
It is normal ? I have only one type of camera :) . I don`t compare to other.
It seems to be a bug. I'll see if I discover the reason.

I tried create basic script to change zoom property. ... set_zoom a.
Script is working, but after script acomplished, manual zoom not working.
I must switch to Prieview mode then back to Capture mode, then manual zoom work again.
Is it normal or bug in my .bas script ?
I have no experience with scripts, but maybe will be helpfull if you post the script that you are running

how I do livieview ? 
liveview is a feature of chdkpt. 
Forum thread: alternative ptp client
« Last Edit: 30 / March / 2013, 20:47:10 by nafraf »

Re: A2400 porting thread
« Reply #46 on: 31 / March / 2013, 05:49:17 »
... if you post the script that you are running
I have two cameras mounted together to take stereo photo. I have USB remote control conneted to boot cam.
I wont set zoom to the same values on booth cameras with script.
All working very pretty :) , but after ran zoob.bas manual zoom is not posible without to switch to other mode and back to P mode.

liveview is a feature of chdkpt. 
Forum thread: alternative ptp client
Thanks.
chdkptp-r311 - ver 100e liveview working.

*

Offline nafraf

  • *****
  • 1308
Re: A2400 porting thread
« Reply #47 on: 31 / March / 2013, 07:39:34 »
All working very pretty :) , but after ran zoob.bas manual zoom is not posible without to switch to other mode and back to P mode.
Same problem was reported here for sx150: Can't adjust zoom after set_zoom()  and I detected the same problem in my a810. I'll try to fix it.


Re: A2400 porting thread
« Reply #48 on: 04 / April / 2013, 14:34:14 »
Some other things tested on a2400IS - 100e :
override - Long exposure, override - short exposure, override ISO working.
ND filter - is present - working.
video quality override - working.
Change video quality in recording mode - how it do it ? - I will try later
Enable flash in video mode - how it do it ? - I will try later

*

Offline nafraf

  • *****
  • 1308
Re: A2400 porting thread
« Reply #49 on: 04 / April / 2013, 20:19:56 »
This version should fix zoom bug.  Please test it and report.
« Last Edit: 10 / April / 2013, 21:29:43 by nafraf »

 

Related Topics