Original firmware for SX210IS - General Chat - CHDK Forum  

Original firmware for SX210IS

  • 4 Replies
  • 2159 Views
Original firmware for SX210IS
« on: 16 / April / 2013, 08:55:24 »
Advertisements
I have an SX210IS and see that there is no CHDK available.

However, I have a problem with the custom white balance on the camera and wondered if a firmware refresh might resolve the issue. I have contacted Canon but they seem unwilling to provide a link to the firmware. (there is no update available).

Does anyone know where I might find the original firmware and reload instructions?

Re: Original firmware for SX210IS
« Reply #1 on: 16 / April / 2013, 09:45:30 »
Typically Canon does not provide firmware updates unless there is a major bug.  That tends to be very rare.

http://chdk.wikia.com/wiki/FAQ#Q._How_can_I_update_the_original_Canon_firmware.3F

http://chdk.wikia.com/wiki/Official_Canon_firmware_updates
Ported :   A1200    SD940   G10    Powershot N    G16

Re: Original firmware for SX210IS
« Reply #2 on: 17 / April / 2013, 10:53:59 »
Thank you for your reply.

I was aware that there was no firmware update available. Based on other computer experience, I thought that reloading the original firmware may have resolved my issue. At least it would have been an easy trouble shooting attempt before the time and expense necessary to return the camera for repair.

Canon didn't seem to agree!

Thanks again

*

Offline reyalp

  • ******
  • 12000
Re: Original firmware for SX210IS
« Reply #3 on: 17 / April / 2013, 23:29:27 »
I was aware that there was no firmware update available. Based on other computer experience, I thought that reloading the original firmware may have resolved my issue. At least it would have been an easy trouble shooting attempt before the time and expense necessary to return the camera for repair.
I doubt that re-flashing the firmware would help. If the firmware code were somehow damaged, the odds are much higher that it would crash than make one specific feature misbehave.

There are "flash parameters" which are also stored in the same flash as the firmware. At least one instance of these getting corrupted has been discussed here before: http://chdk.setepontos.com/index.php?topic=5660.msg55221#msg55221 However, without a more detailed description of what specific problem you are having, it's impossible to say if it might be caused by something like this. I certainly do not recommend taking any of the steps in that thread without a better diagnosis of the problem.
Don't forget what the H stands for.


Re: Original firmware for SX210IS
« Reply #4 on: 22 / April / 2013, 10:18:19 »
Thanks again for the reply,

I guess that I'll have to agree with Canon and return the camera for repair.

FYI - My problem is custom white balance. When I set a custom white balance, the resulting picture has a strong green cast. It doesn't matter in what lighting the custom white balance is set, the result is the same. All other camera functions, including other preset white balance settings, work perfectly.



 

Related Topics