s2is script params not accessible from CHDK menu - General Discussion and Assistance - CHDK Forum supplierdeeply

s2is script params not accessible from CHDK menu

  • 3 Replies
  • 1603 Views
s2is script params not accessible from CHDK menu
« on: 17 / May / 2013, 19:00:06 »
Advertisements
I was completely not sure where to place this thread... Forgive me in advance:)

I have a problem with s2is script params. I am totally new to this cam, however when I have placed a few scripts on the SD cards I can not access params settings. I can see menu like this:

Code: [Select]
Load script from file...
Script Shoot Delay
Autostart
Restart Lua on Error
Load default param values
Parameters set
Save params
-----------AUTOESP 3.0 (←the name of the example script)----------

and nothing more. I can't scroll down, after the last line (Save params) the next highlishted entry is back Load Script from file...

Forgive me if I am missing something. All scripts I have tried have @param lines and AFAIK they were working on sx130 (which I can't test now - the cam is 1000+ km from here for 3 months). On s2is the params sttings are completely lost...

Info:
s2is, firmware 1.00i
CHDK 1.2.0-2785 100g (downloaded as 1.00i)
if (2*b || !2*b) {
    cout<<question
}

Compile error: poor Yorick

*

Online philmoz

  • *****
  • 3201
    • Photos
Re: s2is script params not accessible from CHDK menu
« Reply #1 on: 17 / May / 2013, 19:09:32 »
I was completely not sure where to place this thread... Forgive me in advance:)

I have a problem with s2is script params. I am totally new to this cam, however when I have placed a few scripts on the SD cards I can not access params settings. I can see menu like this:

Code: [Select]
Load script from file...
Script Shoot Delay
Autostart
Restart Lua on Error
Load default param values
Parameters set
Save params
-----------AUTOESP 3.0 (←the name of the example script)----------

and nothing more. I can't scroll down, after the last line (Save params) the next highlishted entry is back Load Script from file...

Forgive me if I am missing something. All scripts I have tried have @param lines and AFAIK they were working on sx130 (which I can't test now - the cam is 1000+ km from here for 3 months). On s2is the params sttings are completely lost...

Info:
s2is, firmware 1.00i
CHDK 1.2.0-2785 100g (downloaded as 1.00i)

If you're using the current trunk version then it appears I broke it when I added the user menu script editor (not just for the s2is).

Stay tuned - I will fix it asap.
Should be fixed in revision 2786.

Phil.
« Last Edit: 17 / May / 2013, 19:18:35 by philmoz »
CHDK ports:
  sx30is (1.00c, 1.00h, 1.00l, 1.00n & 1.00p)
  g12 (1.00c, 1.00e, 1.00f & 1.00g)
  sx130is (1.01d & 1.01f)
  ixus310hs (1.00a & 1.01a)
  sx40hs (1.00d, 1.00g & 1.00i)
  g1x (1.00e, 1.00f & 1.00g)
  g5x (1.00c, 1.01a, 1.01b)
  g7x2 (1.01a, 1.01b, 1.10b)

Re: s2is script params not accessible from CHDK menu
« Reply #2 on: 17 / May / 2013, 19:29:55 »
It's amazing how fast you are. I am waiting for autobuild:) It's slower than any of you, devs! Thx!

EDIT:

Works perfectly!
« Last Edit: 18 / May / 2013, 06:21:51 by outslider »
if (2*b || !2*b) {
    cout<<question
}

Compile error: poor Yorick

Re: s2is script params not accessible from CHDK menu
« Reply #3 on: 20 / May / 2013, 02:11:37 »
--Oh, thread moved-- :)
if (2*b || !2*b) {
    cout<<question
}

Compile error: poor Yorick


 

Related Topics